summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2010-05-18 23:41:29 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2010-05-18 23:41:29 (GMT)
commitf21c313fdfd9237a77a6c8ae52949ad6068e3930 (patch)
tree0e4b3d6e2b845ab2fcb7ffbdfeccb92e2358aa40 /Makefile.am
parentadd611caeebe4c504652f99895c30846af239339 (diff)
Fixed the computing of the revision number.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@158 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 13a6314..0bee3b5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,9 +5,9 @@ BUILT_SOURCES = revision.h
@[ -d $@ ] || touch $@
revision.h: .svn
- @nb=`svn log . -l 1 -q | grep r | cut -d ' ' -f 1 | tr -d 'r'` ; \
+ @nb=`svn log ChangeLog -l 1 -q | grep r | cut -d ' ' -f 1 | tr -d 'r'` ; \
sed -i "s/#define REVISION .*$$/#define REVISION $$nb/" $@ ; \
- [ -f $< ] && rm $<
+ [ -f $< ] && rm $< || true
EXTRA_DIST = config.rpath config.rpath config.rpath config.rpath ChangeLog