summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2018-06-17 13:03:12 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2018-06-17 13:03:12 (GMT)
commit2cb3d9035ef9859570bf8facb1a2cc935743b0b6 (patch)
tree6ad51a7343ac133f6937228e91ca3401f9571324 /configure.ac
parentd152af2b8883fb101cfbdc607601cb963f40db4a (diff)
Got access to external files thanks to new core functions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index f1ac211..3bb72c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -154,14 +154,16 @@ fi
############################################################
AC_ARG_ENABLE(debug, AS_HELP_STRING([--enable-debug], [compile with debugging support [default=no]]),
- [enable_debug=yes], [enable_debug=no])
+ [], [enable_debug=no])
+
+AC_ARG_WITH(local-resources,
+ AS_HELP_STRING([--with-local-resources], [discard resources from local sources [default=yes]]),
+ [], [with_local_resources=yes])
#--- Small enumerations
CFLAGS="$CFLAGS -fshort-enums -D_LARGEFILE64_SOURCE"
-AC_SUBST(CFLAGS)
-
#--- Is debug mode needed ?
if test "x$enable_debug" = "xyes"; then
@@ -172,6 +174,14 @@ fi
AC_SUBST(DEBUG_CFLAGS)
+#--- Discard local sources when looking for resources ?
+
+if test "x$with_local_resources" = "xno"; then
+ CFLAGS="$CFLAGS -DDISCARD_LOCAL"
+fi
+
+AC_SUBST(CFLAGS)
+
#--- Compilation warnings
#-Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes