summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2014-06-25 06:46:04 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2014-06-25 06:46:04 (GMT)
commit3bf12eda58a8d04ac3d2d6754a480de4c262570d (patch)
tree010fc97ad481adc00ac4722d77093f469096638b /configure.ac
parent11395d684736467fb010b93b0eaeefcc06bf0f5e (diff)
Built the first steps to upgrade to Python3.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@379 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 9 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 7982079..e318ba4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,13 +5,13 @@
############################################################
AC_PREREQ(2.59)
-AC_INIT([openida], [0.3.11], [nocbos@gmail.com])
+AC_INIT([chrysalide], [0.3.78], [nocbos@gmail.com])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE
AM_SILENT_RULES
-AM_GNU_GETTEXT_VERSION([0.17])
+AM_GNU_GETTEXT_VERSION([0.18.3])
AM_GNU_GETTEXT([external])
AC_CONFIG_SRCDIR([src/editor.c])
@@ -219,23 +219,23 @@ AC_SUBST(LIBSQLITE_LIBS)
#--- Checks for Python
if test "x$enable_debug" = "xyes"; then
- LIBPYTHON_CFLAGS=`python-dbg-config --cflags`
- LIBPYTHON_LIBS=`python-dbg-config --libs`
+ LIBPYTHON_CFLAGS=`python3-dbg-config --cflags`
+ LIBPYTHON_LIBS=`python3-dbg-config --libs`
else
- LIBPYTHON_CFLAGS=`python-config --cflags`
- LIBPYTHON_LIBS=`python-config --libs`
+ LIBPYTHON_CFLAGS=`python3-config --cflags`
+ LIBPYTHON_LIBS=`python3-config --libs`
fi
AC_SUBST(LIBPYTHON_CFLAGS)
AC_SUBST(LIBPYTHON_LIBS)
-#--- Checks for pygobject-2.0
+#--- Checks for pygobject-3.0
-PKG_CHECK_MODULES(LIBPYGOBJECT,pygobject-2.0 >= 2.21.1,[libpygobject_found=yes],[libpygobject_found=no])
+PKG_CHECK_MODULES(LIBPYGOBJECT,pygobject-3.0 >= 3.12.1,[libpygobject_found=yes],[libpygobject_found=no])
if test "$libpygobject_found" = "yes"; then
- libpygobject_version=`pkg-config pygobject-2.0 --modversion`
+ libpygobject_version=`pkg-config pygobject-3.0 --modversion`
else
libpygobject_version='-'
fi