summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2015-11-03 21:49:14 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2015-11-03 21:49:14 (GMT)
commit72da49fdf05285169a9465b34f7869dafc4715ec (patch)
tree8a7303076d85c977737d2e30ac8eaf1da0a909a3 /configure.ac
parent565c3f494b51715cf67575fc5951c6103049f29d (diff)
Retrieved the revision number using M4 instead of shell.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@603 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 3f0478f..1476908 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,8 +4,10 @@
# Autoconf requirements
############################################################
+m4_include([svnrev.m4])
+
AC_PREREQ(2.59)
-AC_INIT([chrysalide], [0.3.78], [nocbos@gmail.com])
+AC_INIT([chrysalide], [svnversion], [nocbos@gmail.com])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])
@@ -89,14 +91,14 @@ AC_CHECK_FUNCS([strrchr])
#--- Autoheader Macros
-AH_TEMPLATE([VERSION], [Define the version number of the program for the about box.])
+AH_TEMPLATE([REVISION], [Define the version number of the program for the about box.])
AH_TEMPLATE([PACKAGE_DATA_DIR], [Define the directory where the associated data will be installed.])
AH_TEMPLATE([PACKAGE_SOURCE_DIR], [Define the directory where the code source is waiting for being compiled.])
AH_TEMPLATE([PLUGINS_DIR], [Define the directory where the plugins are installed.])
AH_TEMPLATE([LOCALE_DIR], [Define the directory where the message catalogs are installed.])
-AC_DEFINE_UNQUOTED(VERSION, AC_PACKAGE_VERSION)
+AC_DEFINE_UNQUOTED(REVISION, AC_PACKAGE_VERSION)
if test "x${datadir}" = 'x${prefix}/share'; then
if test "x${prefix}" = "xNONE"; then
@@ -363,7 +365,7 @@ AC_OUTPUT
echo
-echo $PACKAGE $VERSION
+echo $PACKAGE REVISION
echo
echo The GNU Image Manipulation Program Toolkit... : $libgtk_version