summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2016-04-09 15:12:06 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2016-04-09 15:12:06 (GMT)
commit865be356c53afc3bdeae21c640bf0c3d5433fc4b (patch)
tree1204a61960a417b6964b4aef245576e0f790ac20 /configure.ac
parent9b7dfd449b08637c4b4fc6d95acf3a8fcb5fd58d (diff)
Created user public and private RSA keys if needed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6c7a62e..e326fe8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -220,6 +220,20 @@ AC_SUBST(LIBSQLITE_CFLAGS)
AC_SUBST(LIBSQLITE_LIBS)
+#--- Checks for libssl
+
+PKG_CHECK_MODULES(LIBSSL,libssl >= 1.0.1k,[libssl_found=yes],[libssl_found=no])
+
+if test "$libssl_found" = "yes"; then
+ libssl_version=`pkg-config libssl --modversion`
+else
+ libssl_version='-'
+fi
+
+AC_SUBST(LIBSSL_CFLAGS)
+AC_SUBST(LIBSSL_LIBS)
+
+
#--- Checks for Python
if test "x$enable_debug" = "xyes"; then
@@ -400,6 +414,7 @@ echo The GNU Image Manipulation Program Toolkit... : $libgtk_version
echo The XML C parser and toolkit of Gnome........ : $libxml_version
echo The flexible interface for archives I/O...... : $libarchive_version
echo The small, fast and reliable database engine. : $libsqlite_version
+echo The cryptography and SSL/TLS toolkit......... : $libssl_version
echo
echo Available Python programming language........ : $python3_version