summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2021-03-23 21:14:27 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2021-03-23 21:14:27 (GMT)
commit9134efeda85c0c202ccc8006f4387eed04581242 (patch)
tree0fde9ec06b92750157d444321db5836b874cb033 /configure.ac
parent8df9996699cdf96887613f99181173295a19bd76 (diff)
Register missing requirements for the pkg-config metadata file.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5f10574..ff02f65 100644
--- a/configure.ac
+++ b/configure.ac
@@ -387,10 +387,12 @@ if test "x$python3_cfg_binary" = "xyes"; then
LIBPYTHON_CFLAGS=`python3-dbg-config --cflags`
LIBPYTHON_LIBS=`python3-dbg-config --libs`
LIBPYTHON_ABI_FLAGS=`python3-dbg-config --abiflags`
+ pythondep="python3-dbg"
else
LIBPYTHON_CFLAGS=`python3-config --cflags`
LIBPYTHON_LIBS=`python3-config --libs`
LIBPYTHON_ABI_FLAGS=`python3-config --abiflags`
+ pythondep="python3"
fi
AC_SUBST(LIBPYTHON_CFLAGS)
@@ -405,6 +407,7 @@ if test "x$python3_cfg_binary" = "xyes"; then
else
+ pythondep=
python3_version='-'
fi
@@ -420,6 +423,13 @@ if test "$libpygobject_found" = "yes"; then
else
libpygobject_version="`pkg-config pygobject-3.0 --modversion` (skipped)"
fi
+
+ if test "x$pythondep" = "x"; then
+ pythondep="pygobject-3.0"
+ else
+ pythondep="$pythondep pygobject-3.0"
+ fi
+
else
libpygobject_version='-'
fi
@@ -427,6 +437,8 @@ fi
AC_SUBST(LIBPYGOBJECT_CFLAGS)
AC_SUBST(LIBPYGOBJECT_LIBS)
+AC_SUBST(pythondep)
+
############################################################
# Outputting files