summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2016-10-29 11:55:02 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2016-10-29 11:55:02 (GMT)
commit945f58cb1e1b8b6dc444dd0668bd1a2986cd899e (patch)
tree1fc255ced81920e46036699cc55ffc9962807cc2 /configure.ac
parent38e455ebbbbf90ddbf552f95a1dfb3c544907587 (diff)
Told GCC to pack enumerations to save memory space.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ca54caa..c34cfb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -141,6 +141,11 @@ fi
AC_ARG_ENABLE(debug, [ --enable-debug compile with debugging support [def=no]], [enable_debug=yes], [enable_debug=no])
+#--- Small enumerations
+
+CFLAGS="$CFLAGS -fshort-enums"
+
+AC_SUBST(CFLAGS)
#--- Is debug mode needed ?