summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2017-07-12 13:07:55 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2017-07-12 13:08:42 (GMT)
commita331ff258895865049bf79bc1629dbc744b7faf5 (patch)
treec4f649ba21afcacf974cc6536f03aa97663a9acd /configure.ac
parent9b018cede5af54594c0a20847239233153b04ce1 (diff)
Removed the too complex memory share system.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 0 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index fbf9bd4..aadb326 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,21 +142,12 @@ fi
AC_ARG_ENABLE(debug, AS_HELP_STRING([--enable-debug], [compile with debugging support [default=no]]),
[enable_debug=yes], [enable_debug=no])
-AC_ARG_ENABLE(dump_stats, AS_HELP_STRING([--enable-dump-stats], [display share statistics if debug is enabled [default=no]]),
- [enable_dump_stats=yes], [enable_dump_stats=no])
-
#--- Small enumerations
CFLAGS="$CFLAGS -fshort-enums"
AC_SUBST(CFLAGS)
-#--- Dump share statistics ?
-
-if test "x$enable_dump_stats" = "xyes"; then
- DEBUG_CFLAGS="$DEBUG_CFLAGS -DDEBUG_DUMP_STATS"
-fi
-
#--- Is debug mode needed ?
if test "x$enable_debug" = "xyes"; then
@@ -365,7 +356,6 @@ AC_CONFIG_FILES([Makefile
src/arch/dalvik/opcodes/Makefile
src/arch/dalvik/operands/Makefile
src/arch/dalvik/pseudo/Makefile
- src/arch/sharing/Makefile
src/common/Makefile
src/core/Makefile
src/debug/Makefile
@@ -429,7 +419,6 @@ echo Found general-purpose parser generator....... : $YACC_INST
echo
echo Print debugging messages..................... : $enable_debug
-echo Display share statistics for loaded binaries..: $enable_dump_stats
if test -z "$LEX_INST" -o -z "$YACC_INST"; then