summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2020-08-18 20:08:39 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2020-08-18 20:08:39 (GMT)
commitc5631dd09fa9981e914ec9082c6270b69a719ca4 (patch)
tree0d50b3a82f466d2b8587ad20cfb0c93b180897ee /configure.ac
parente5185bf4b4b6f76f15d3ff460a9cea40a8753284 (diff)
Refreshed the rendering for newly added bookmarks.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f467f66..855091f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,6 +60,23 @@ AC_CHECK_HEADERS([unistd.h])
AC_TYPE_SIZE_T
+AC_MSG_CHECKING([for suitable size_t])
+AC_COMPILE_IFELSE( [AC_LANG_PROGRAM([[#include <stddef.h>]],
+ [[char dummy[sizeof(size_t) == sizeof(unsigned long) ? 1 : -1];]])],
+ [
+ AC_MSG_RESULT([yes])
+ suitable_size_t=yes
+ ],
+ [
+ AC_MSG_RESULT([no])
+ suitable_size_t=no
+ ]
+ )
+
+if test "x$suitable_size_t" = "xno"; then
+ AC_MSG_FAILURE([Current size of size_t is not supported])
+fi
+
#--- Checks for structures