summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2016-03-01 20:38:03 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2016-03-01 20:38:03 (GMT)
commit71f3b31f2e05dc3ed8201c409c9b9f39eb8bdfe0 (patch)
tree0592f686d321b3017b27e2df09e5c3c4e4ebbfff /plugins/Makefile.am
parent2245e2b3c4f4ff96cf462e76e24c04d4d0941996 (diff)
Prevented compilation from breaking when Python3 is not found.
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 726534f..22ef693 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,2 +1,6 @@
-SUBDIRS = androhelpers devdbg libcsem mobicore pychrysa python readelf ropgadgets stackvars
+if HAVE_PYTHON3_CONFIG
+ PYTHON3_SUBDIRS = pychrysa python
+endif
+
+SUBDIRS = androhelpers devdbg libcsem mobicore $(PYTHON3_SUBDIRS) readelf ropgadgets stackvars