summaryrefslogtreecommitdiff
path: root/plugins/arm/v7/opdefs/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2018-10-30 21:53:30 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2018-10-30 21:53:30 (GMT)
commit65e12afde4bd9cd32e206f874cfa378708248918 (patch)
treef20703aa76917732b65781c8b45c2a356224bdc1 /plugins/arm/v7/opdefs/Makefile.am
parentb48aa163302c32be9624782015507c1138b13d59 (diff)
Defined the parent directory as the working location for generation.
Diffstat (limited to 'plugins/arm/v7/opdefs/Makefile.am')
-rw-r--r--plugins/arm/v7/opdefs/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/plugins/arm/v7/opdefs/Makefile.am b/plugins/arm/v7/opdefs/Makefile.am
index 59b69a4..2fb3c4a 100644
--- a/plugins/arm/v7/opdefs/Makefile.am
+++ b/plugins/arm/v7/opdefs/Makefile.am
@@ -6,7 +6,7 @@ D2C_BIN = $(top_srcdir)/tools/d2c/d2c
GEN_BIN = $(top_srcdir)/tools/d2c/d2c_genmakefile.sh
-D2C_OUTDIR = $(PWD)/../opcodes/
+D2C_OUTDIR = $(shell readlink -f $(PWD)/.. )/
D2C_TYPE = raw
@@ -461,7 +461,7 @@ dist-hook:
all: $(ARMV7_DEFS:.d=.g) fmk.done d2c_final_rules
fmk.done: $(ARMV7_DEFS)
- $(GEN_BIN) $(D2C_OUTDIR) arm thumb_32 thumb_16
+ $(GEN_BIN) $(D2C_OUTDIR)opcodes/ arm thumb_32 thumb_16
touch $@
clean: