summaryrefslogtreecommitdiff
path: root/plugins/dwarf/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2018-11-24 11:41:13 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2018-11-24 11:41:13 (GMT)
commitdad453ff553f0ab07206f26345dc0adeffb775fd (patch)
tree322f3b26da0d0d25011b7e64afc7c7ee37aa5608 /plugins/dwarf/Makefile.am
parent615171f171f53791a25aeab7970e29b024177d48 (diff)
Moved the DWARF support as plugin and disabled it.
Diffstat (limited to 'plugins/dwarf/Makefile.am')
-rw-r--r--plugins/dwarf/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/plugins/dwarf/Makefile.am b/plugins/dwarf/Makefile.am
new file mode 100644
index 0000000..3020643
--- /dev/null
+++ b/plugins/dwarf/Makefile.am
@@ -0,0 +1,39 @@
+
+noinst_LTLIBRARIES = libformatdwarf.la
+
+libformatdwarf_la_SOURCES = \
+ abbrev.h abbrev.c \
+ die.h die.c \
+ dwarf.h dwarf.c \
+ dwarf-int.h dwarf-int.c \
+ dwarf_def.h \
+ form.h form.c \
+ info.h info.c \
+ symbols.h symbols.c
+
+# libformatdwarf_la_SOURCES = \
+# abbrev.h abbrev.c \
+# dwarf.h dwarf.c \
+# d_dwarf.h d_dwarf.c \
+# dwarf_def.h \
+# info.h info.c \
+# utils.h utils.c
+
+libformatdwarf_la_LIBADD = \
+ v2/libformatdwarfv2.la \
+ v3/libformatdwarfv3.la \
+ v4/libformatdwarfv4.la
+
+libformatdwarf_la_LDFLAGS = $(LIBGTK_LIBS)
+
+
+devdir = $(includedir)/chrysalide/$(subdir:src/%=%)
+
+dev_HEADERS = $(libformatdwarf_la_SOURCES:%c=)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
+
+SUBDIRS = v2 v3 v4