summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 15 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0233317..1ee20a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -219,8 +219,8 @@ AC_ARG_WITH(gobject-leak-tracker,
[], [with_gobject_leak_tracker=no])
AC_ARG_WITH(local-resources,
- AS_HELP_STRING([--with-local-resources], [discard resources from local sources [default=yes]]),
- [], [with_local_resources=yes])
+ AS_HELP_STRING([--with-desktop-dir=PATH],
+ [specify to destination of desktop files (default=PREFIX/share)]))
#--- Small enumerations
@@ -261,6 +261,18 @@ AM_CONDITIONAL([BUILD_DISCARD_LOCAL], [test "x$with_local_resources" = "xno"])
AC_SUBST(CFLAGS)
+#--- Custom destination for desktop resources ?
+
+if test "x$with_desktop_dir" != x; then
+ DESKTOP_DATADIR=$with_desktop_dir
+else
+ DESKTOP_DATADIR="$datadir"
+fi
+
+AM_CONDITIONAL(DESKTOP_DATADIR, test "x$with_desktop_dir" != xno)
+AC_SUBST(DESKTOP_DATADIR)
+
+
#--- Compilation warnings
#-Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes
@@ -546,6 +558,7 @@ AC_CONFIG_FILES([Makefile
tools/d2c/pattern/Makefile
tools/d2c/rules/Makefile
system/Makefile
+ system/desktop/Makefile
system/pkgconfig/Makefile
themes/Makefile
themes/Adwaita/Makefile