summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5c383a7..fbda04a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -395,6 +395,20 @@ AC_SUBST(LIBSSL_CFLAGS)
AC_SUBST(LIBSSL_LIBS)
+#--- Checks for libcurl
+
+PKG_CHECK_MODULES(LIBCURL,libcurl >= 7.64,[libcurl_found=yes],[libcurl_found=no])
+
+if test "$libcurl_found" = "yes"; then
+ libcurl_version=`pkg-config libcurl --modversion`
+else
+ libcurl_version='-'
+fi
+
+AC_SUBST(LIBCURL_CFLAGS)
+AC_SUBST(LIBCURL_LIBS)
+
+
#--- Checks for Python
if test "x$enable_debug" = "xyes"; then
@@ -628,6 +642,7 @@ echo The XML C parser and toolkit of Gnome........ : $libxml_version
echo The flexible interface for archives I/O...... : $libarchive_version
echo The small, fast and reliable database engine. : $libsqlite_version
echo The cryptography and SSL/TLS toolkit......... : $libssl_version
+echo The client URL library....................... : $libcurl_version
echo
echo Available Python programming language........ : $python3_version