summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b7166ed..d6a96b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -139,7 +139,11 @@ fi
# Compilation options
############################################################
-AC_ARG_ENABLE(debug, [ --enable-debug compile with debugging support [def=no]], [enable_debug=yes], [enable_debug=no])
+AC_ARG_ENABLE(debug, AS_HELP_STRING([--enable-debug], [compile with debugging support [default=no]]),
+ [enable_debug=yes], [enable_debug=no])
+
+AC_ARG_ENABLE(dump_stats, AS_HELP_STRING([--enable-dump-stats], [display share statistics if debug is enabled [default=no]]),
+ [enable_dump_stats=yes], [enable_dump_stats=no])
#--- Small enumerations
@@ -147,6 +151,12 @@ CFLAGS="$CFLAGS -fshort-enums"
AC_SUBST(CFLAGS)
+#--- Dump share statistics ?
+
+if test "x$enable_dump_stats" = "xyes"; then
+ DEBUG_CFLAGS="$DEBUG_CFLAGS -DDEBUG_DUMP_STATS"
+fi
+
#--- Is debug mode needed ?
if test "x$enable_debug" = "xyes"; then
@@ -155,6 +165,8 @@ fi
AC_SUBST(DEBUG_CFLAGS)
+#--- Compilation warnings
+
#-Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes
WARNING_FLAGS="-Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes"
@@ -428,6 +440,7 @@ echo Found general-purpose parser generator....... : $YACC_INST
echo
echo Print debugging messages..................... : $enable_debug
+echo Display share statistics for loaded binaries..: $enable_dump_stats
if test -z "$LEX_INST" -o -z "$YACC_INST"; then