summaryrefslogtreecommitdiff
path: root/plugins/govm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/govm/Makefile.am')
-rw-r--r--plugins/govm/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/plugins/govm/Makefile.am b/plugins/govm/Makefile.am
new file mode 100644
index 0000000..7d3e212
--- /dev/null
+++ b/plugins/govm/Makefile.am
@@ -0,0 +1,43 @@
+
+BUILT_SOURCES = gram.h
+
+AM_YFLAGS = -d
+
+lib_LTLIBRARIES = libarchgovm.la
+
+bin_PROGRAMS = goas
+
+
+#--- liboidadisas
+
+libarchgovm_la_SOURCES = \
+ instruction.h instruction.c
+
+libarchgovm_la_LDFLAGS =
+
+libarchgovm_la_LIBADD =
+
+
+#--- goas
+
+goas_SOURCES = \
+ build.h build.c \
+ goas.c \
+ gram.y \
+ tok.l
+
+
+INCLUDES =
+
+AM_CPPFLAGS =
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
+
+
+goas_LDFLAGS = -L.libs
+
+goas_LDADD = $(LIBINTL) -larchgovm
+
+
+# Automake fait les choses à moitié
+CLEANFILES = gram.h gram.c tok.c