summaryrefslogtreecommitdiff
path: root/plugins/readdex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/readdex/Makefile.am')
-rw-r--r--plugins/readdex/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/plugins/readdex/Makefile.am b/plugins/readdex/Makefile.am
index e4d961a..b21f855 100644
--- a/plugins/readdex/Makefile.am
+++ b/plugins/readdex/Makefile.am
@@ -4,6 +4,17 @@ lib_LTLIBRARIES = libreaddex.la
libdir = $(pluginslibdir)
+if BUILD_PYTHON_PACKAGE
+
+RUN_PATH = -Wl,-rpath,'$$ORIGIN/../chrysalide-libs:$$ORIGIN'
+
+else
+
+RUN_PATH = -Wl,-rpath,'$$ORIGIN'
+
+endif
+
+
libreaddex_la_SOURCES = \
class.h class.c \
code.h code.c \
@@ -12,9 +23,11 @@ libreaddex_la_SOURCES = \
reader.h reader.c
libreaddex_la_LDFLAGS = \
+ -avoid-version \
-L$(top_srcdir)/src/.libs -lchrysacore \
-L$(top_srcdir)/plugins/dex/.libs -ldex \
- -L$(top_srcdir)/plugins/fmtp/.libs -lfmtp
+ -L$(top_srcdir)/plugins/fmtp/.libs -lfmtp \
+ $(RUN_PATH)
devdir = $(includedir)/chrysalide/$(subdir)