summaryrefslogtreecommitdiff
path: root/plugins/readmc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/readmc/Makefile.am')
-rw-r--r--plugins/readmc/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/plugins/readmc/Makefile.am b/plugins/readmc/Makefile.am
index 1c63ccd..fa13fb2 100644
--- a/plugins/readmc/Makefile.am
+++ b/plugins/readmc/Makefile.am
@@ -4,6 +4,17 @@ lib_LTLIBRARIES = libreadmc.la
libdir = $(pluginslibdir)
+if BUILD_PYTHON_PACKAGE
+
+RUN_PATH = -Wl,-rpath,'$$ORIGIN/../chrysalide-libs:$$ORIGIN'
+
+else
+
+RUN_PATH = -Wl,-rpath,'$$ORIGIN'
+
+endif
+
+
libreadmc_la_SOURCES = \
header.h header.c \
reader.h reader.c \
@@ -13,9 +24,11 @@ libreadmc_la_SOURCES = \
v24.h v24.c
libreadmc_la_LDFLAGS = \
+ -avoid-version \
-L$(top_srcdir)/src/.libs -lchrysacore \
-L$(top_srcdir)/plugins/mobicore/.libs -lmobicore \
- -L$(top_srcdir)/plugins/fmtp/.libs -lfmtp
+ -L$(top_srcdir)/plugins/fmtp/.libs -lfmtp \
+ $(RUN_PATH)
devdir = $(includedir)/chrysalide/$(subdir)