summaryrefslogtreecommitdiff
path: root/plugins/ropgadgets/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/ropgadgets/Makefile.am')
-rw-r--r--plugins/ropgadgets/Makefile.am15
1 files changed, 14 insertions, 1 deletions
diff --git a/plugins/ropgadgets/Makefile.am b/plugins/ropgadgets/Makefile.am
index 3cb5e9a..f23e054 100644
--- a/plugins/ropgadgets/Makefile.am
+++ b/plugins/ropgadgets/Makefile.am
@@ -4,6 +4,17 @@ lib_LTLIBRARIES = libropgadgets.la
libdir = $(pluginslibdir)
+if BUILD_PYTHON_PACKAGE
+
+RUN_PATH = -Wl,-rpath,'$$ORIGIN/../chrysalide-libs:$$ORIGIN'
+
+else
+
+RUN_PATH = -Wl,-rpath,'$$ORIGIN'
+
+endif
+
+
libropgadgets_la_SOURCES = \
finder.h finder.c \
helper.h helper.c \
@@ -12,8 +23,10 @@ libropgadgets_la_SOURCES = \
select.h select.c
libropgadgets_la_LDFLAGS = \
+ -avoid-version \
-L$(top_srcdir)/src/.libs -lchrysacore \
- -L$(top_srcdir)/plugins/arm/.libs -larm
+ -L$(top_srcdir)/plugins/arm/.libs -larm \
+ $(RUN_PATH)
devdir = $(includedir)/chrysalide/$(subdir)