summaryrefslogtreecommitdiff
path: root/src/format/pe/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/format/pe/Makefile.am')
-rw-r--r--src/format/pe/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/format/pe/Makefile.am b/src/format/pe/Makefile.am
new file mode 100644
index 0000000..00050a5
--- /dev/null
+++ b/src/format/pe/Makefile.am
@@ -0,0 +1,21 @@
+
+noinst_LTLIBRARIES = libformatpe.la
+
+libformatpe_la_SOURCES = \
+ pe-int.h pe-int.c \
+ pe.h pe.c \
+ pe_def.h \
+ section.h section.c \
+ symbols.h symbols.c
+
+libformatpe_la_LDFLAGS =
+
+
+devdir = $(includedir)/chrysalide/$(subdir:src/%=%)
+
+dev_HEADERS = $(libformatpe_la_SOURCES:%c=)
+
+
+AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)