From 70ed4dc99c75c13797b41164959c753ffbc4572b Mon Sep 17 00:00:00 2001
From: Cyrille Bagard <nocbos@gmail.com>
Date: Fri, 28 Mar 2025 05:50:02 +0100
Subject: Perform small code updates for operands.

---
 src/arch/operand-int.h          | 23 ++++++++++++-----------
 src/arch/operand-ui.h           |  1 -
 src/arch/operand.c              |  6 +++---
 src/arch/operands/Makefile.am   |  4 ++--
 src/arch/operands/immediate.c   |  6 +++---
 src/arch/operands/known.c       |  6 +++---
 src/arch/operands/register-ui.h |  2 +-
 src/arch/operands/register.c    |  6 +++---
 8 files changed, 27 insertions(+), 27 deletions(-)

diff --git a/src/arch/operand-int.h b/src/arch/operand-int.h
index a83d135..10c079b 100644
--- a/src/arch/operand-int.h
+++ b/src/arch/operand-int.h
@@ -26,8 +26,6 @@
 
 
 #include "operand.h"
-
-
 #include "../common/szbin.h"
 #include "../glibext/objhole-int.h"
 
@@ -88,15 +86,6 @@ typedef bool (* store_operand_fc) (GArchOperand *, GObjectStorage *, packed_buff
 #endif
 
 
-#define ARCH_OPERAND_EXTRA_DATA(mx)                         \
-                                                            \
-    unsigned int reserved : GOBJECT_RESERVED_EXTRA_BITS;    \
-                                                            \
-    /**                                                     \
-     * ArchOperandFlag                                      \
-     */                                                     \
-    unsigned int flags : mx;
-
 
 /* Définition générique d'un opérande d'architecture (instance) */
 struct _GArchOperand
@@ -137,10 +126,22 @@ struct _GArchOperandClass
 };
 
 
+
 /**
  * Accès aux informations éventuellement déportées.
  */
 
+
+#define ARCH_OPERAND_EXTRA_DATA(mx)                         \
+                                                            \
+    unsigned int reserved : GOBJECT_RESERVED_EXTRA_BITS;    \
+                                                            \
+    /**                                                     \
+     * ArchOperandFlag                                      \
+     */                                                     \
+    unsigned int flags : mx;
+
+
 /* Informations glissées dans la structure GObject de GArchOperand */
 typedef struct _operand_extra_data_t
 {
diff --git a/src/arch/operand-ui.h b/src/arch/operand-ui.h
index 4aacab7..b197645 100644
--- a/src/arch/operand-ui.h
+++ b/src/arch/operand-ui.h
@@ -25,7 +25,6 @@
 #define _ARCH_OPERAND_UI_H
 
 
-
 #include "../glibext/bufferline.h"
 #include "../glibext/helpers.h"
 
diff --git a/src/arch/operand.c b/src/arch/operand.c
index f2f356b..d3e837c 100644
--- a/src/arch/operand.c
+++ b/src/arch/operand.c
@@ -51,7 +51,7 @@ static void g_arch_operand_comparable_object_iface_init(GComparableObjectInterfa
 static void g_arch_operand_hashable_object_iface_init(GHashableObjectInterface *);
 
 /* Procède à l'initialisation de l'interface de sérialisation. */
-static void g_arch_operand_serializable_iface_init(GSerializableObjectInterface *);
+static void g_arch_operand_serializable_object_iface_init(GSerializableObjectInterface *);
 
 /* Procède à l'initialisation de l'interface de rassemblement. */
 static void g_arch_operand_singleton_candidate_iface_init(GSingletonCandidateInterface *);
@@ -117,7 +117,7 @@ static bool g_arch_operand_is_read_only(const GSingletonCandidate *);
 G_DEFINE_TYPE_WITH_CODE(GArchOperand, g_arch_operand, G_TYPE_THICK_OBJECT,
                         G_IMPLEMENT_INTERFACE(G_TYPE_COMPARABLE_OBJECT, g_arch_operand_comparable_object_iface_init)
                         G_IMPLEMENT_INTERFACE(G_TYPE_HASHABLE_OBJECT, g_arch_operand_hashable_object_iface_init)
-                        G_IMPLEMENT_INTERFACE(G_TYPE_SERIALIZABLE_OBJECT, g_arch_operand_serializable_iface_init)
+                        G_IMPLEMENT_INTERFACE(G_TYPE_SERIALIZABLE_OBJECT, g_arch_operand_serializable_object_iface_init)
                         G_IMPLEMENT_INTERFACE(G_TYPE_SINGLETON_CANDIDATE, g_arch_operand_singleton_candidate_iface_init)
                         G_IMPLEMENT_INTERFACE(G_TYPE_STRING_BUILDER, g_arch_operand_string_builder_iface_init));
 
@@ -196,7 +196,7 @@ static void g_arch_operand_hashable_object_iface_init(GHashableObjectInterface *
 *                                                                             *
 ******************************************************************************/
 
-static void g_arch_operand_serializable_iface_init(GSerializableObjectInterface *iface)
+static void g_arch_operand_serializable_object_iface_init(GSerializableObjectInterface *iface)
 {
     iface->load = g_arch_operand_load;
     iface->store = g_arch_operand_store;
diff --git a/src/arch/operands/Makefile.am b/src/arch/operands/Makefile.am
index 9dc3b2f..3d9cbde 100644
--- a/src/arch/operands/Makefile.am
+++ b/src/arch/operands/Makefile.am
@@ -21,14 +21,14 @@ libarchoperands_la_SOURCES =			\
 	register-int.h						\
 	register.h register.c
 
-libarchoperands_la_CFLAGS = $(TOOLKIT_CFLAGS)
+libarchoperands_la_CFLAGS = $(LIBGOBJ_CFLAGS)
 
 libarchoperandsui_la_SOURCES =			\
 	immediate-ui.h immediate-ui.c		\
 	known-ui.h known-ui.c				\
 	register-ui.h register-ui.c
 
-libarchoperandsui_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBGTK4_CFLAGS)
+libarchoperandsui_la_CFLAGS = $(LIBGTK4_CFLAGS)
 
 
 devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)
diff --git a/src/arch/operands/immediate.c b/src/arch/operands/immediate.c
index 7ec5ebd..f99b421 100644
--- a/src/arch/operands/immediate.c
+++ b/src/arch/operands/immediate.c
@@ -67,7 +67,7 @@ static void g_immediate_operand_comparable_object_iface_init(GComparableObjectIn
 static void g_immediate_operand_hashable_object_iface_init(GHashableObjectInterface *);
 
 /* Procède à l'initialisation de l'interface de sérialisation. */
-static void g_immediate_operand_serializable_iface_init(GSerializableObjectInterface *);
+static void g_immediate_operand_serializable_object_iface_init(GSerializableObjectInterface *);
 
 /* Procède à l'initialisation de l'interface d'exportation. */
 static void g_immediate_operand_string_builder_iface_init(GStringBuilderInterface *, gpointer);
@@ -139,7 +139,7 @@ static bool g_immediate_operand_to_string(const GStringBuilder *, unsigned int,
 G_DEFINE_TYPE_WITH_CODE(GImmediateOperand, g_immediate_operand, G_TYPE_ARCH_OPERAND,
                         G_IMPLEMENT_INTERFACE(G_TYPE_COMPARABLE_OBJECT, g_immediate_operand_comparable_object_iface_init)
                         G_IMPLEMENT_INTERFACE(G_TYPE_HASHABLE_OBJECT, g_immediate_operand_hashable_object_iface_init)
-                        G_IMPLEMENT_INTERFACE(G_TYPE_SERIALIZABLE_OBJECT, g_immediate_operand_serializable_iface_init)
+                        G_IMPLEMENT_INTERFACE(G_TYPE_SERIALIZABLE_OBJECT, g_immediate_operand_serializable_object_iface_init)
                         G_IMPLEMENT_INTERFACE(G_TYPE_STRING_BUILDER, g_immediate_operand_string_builder_iface_init)
                         G_IMPLEMENT_INTERFACE_IF_SYM(g_arch_operand_ui_get_type, g_immediate_operand_ui_arch_operand_ui_iface_init));
 
@@ -218,7 +218,7 @@ static void g_immediate_operand_hashable_object_iface_init(GHashableObjectInterf
 *                                                                             *
 ******************************************************************************/
 
-static void g_immediate_operand_serializable_iface_init(GSerializableObjectInterface *iface)
+static void g_immediate_operand_serializable_object_iface_init(GSerializableObjectInterface *iface)
 {
     iface->load = g_immediate_operand_load;
     iface->store = g_immediate_operand_store;
diff --git a/src/arch/operands/known.c b/src/arch/operands/known.c
index adb700d..c9e177f 100644
--- a/src/arch/operands/known.c
+++ b/src/arch/operands/known.c
@@ -50,7 +50,7 @@ static void g_known_immediate_operand_comparable_object_iface_init(GComparableOb
 static void g_known_immediate_operand_hashable_object_iface_init(GHashableObjectInterface *);
 
 /* Procède à l'initialisation de l'interface de sérialisation. */
-static void g_known_immediate_operand_serializable_iface_init(GSerializableObjectInterface *);
+static void g_known_immediate_operand_serializable_object_iface_init(GSerializableObjectInterface *);
 
 /* Procède à l'initialisation de l'interface d'exportation. */
 static void g_known_immediate_operand_string_builder_iface_init(GStringBuilderInterface *);
@@ -110,7 +110,7 @@ static bool g_known_immediate_operand_to_string(const GStringBuilder *, unsigned
 G_DEFINE_TYPE_WITH_CODE(GKnownImmediateOperand, g_known_immediate_operand, G_TYPE_IMMEDIATE_OPERAND,
                         G_IMPLEMENT_INTERFACE(G_TYPE_COMPARABLE_OBJECT, g_known_immediate_operand_comparable_object_iface_init)
                         G_IMPLEMENT_INTERFACE(G_TYPE_HASHABLE_OBJECT, g_known_immediate_operand_hashable_object_iface_init)
-                        G_IMPLEMENT_INTERFACE(G_TYPE_SERIALIZABLE_OBJECT, g_known_immediate_operand_serializable_iface_init)
+                        G_IMPLEMENT_INTERFACE(G_TYPE_SERIALIZABLE_OBJECT, g_known_immediate_operand_serializable_object_iface_init)
                         G_IMPLEMENT_INTERFACE(G_TYPE_STRING_BUILDER, g_known_immediate_operand_string_builder_iface_init)
                         G_IMPLEMENT_INTERFACE_IF_SYM(g_arch_operand_ui_get_type, g_known_immediate_operand_ui_arch_operand_ui_iface_init));
 
@@ -189,7 +189,7 @@ static void g_known_immediate_operand_hashable_object_iface_init(GHashableObject
 *                                                                             *
 ******************************************************************************/
 
-static void g_known_immediate_operand_serializable_iface_init(GSerializableObjectInterface *iface)
+static void g_known_immediate_operand_serializable_object_iface_init(GSerializableObjectInterface *iface)
 {
     iface->load = g_known_immediate_operand_load;
     iface->store = g_known_immediate_operand_store;
diff --git a/src/arch/operands/register-ui.h b/src/arch/operands/register-ui.h
index 711f450..16be67b 100644
--- a/src/arch/operands/register-ui.h
+++ b/src/arch/operands/register-ui.h
@@ -25,7 +25,7 @@
 #define _ARCH_OPERANDS_REGISTER_UI_H
 
 
-#include "../operand-ui-int.h"
+#include "../operand-ui-int.h"      // FIXME ??
 
 
 
diff --git a/src/arch/operands/register.c b/src/arch/operands/register.c
index 07e35c4..cad2c4e 100644
--- a/src/arch/operands/register.c
+++ b/src/arch/operands/register.c
@@ -48,7 +48,7 @@ static void g_register_operand_comparable_object_iface_init(GComparableObjectInt
 static void g_register_operand_hashable_object_iface_init(GHashableObjectInterface *);
 
 /* Procède à l'initialisation de l'interface de sérialisation. */
-static void g_register_operand_serializable_iface_init(GSerializableObjectInterface *);
+static void g_register_operand_serializable_object_iface_init(GSerializableObjectInterface *);
 
 /* Procède à l'initialisation de l'interface d'exportation. */
 static void g_register_operand_string_builder_iface_init(GStringBuilderInterface *);
@@ -108,7 +108,7 @@ static bool g_register_operand_to_string(const GStringBuilder *, unsigned int, s
 G_DEFINE_TYPE_WITH_CODE(GRegisterOperand, g_register_operand, G_TYPE_ARCH_OPERAND,
                         G_IMPLEMENT_INTERFACE(G_TYPE_COMPARABLE_OBJECT, g_register_operand_comparable_object_iface_init)
                         G_IMPLEMENT_INTERFACE(G_TYPE_HASHABLE_OBJECT, g_register_operand_hashable_object_iface_init)
-                        G_IMPLEMENT_INTERFACE(G_TYPE_SERIALIZABLE_OBJECT, g_register_operand_serializable_iface_init)
+                        G_IMPLEMENT_INTERFACE(G_TYPE_SERIALIZABLE_OBJECT, g_register_operand_serializable_object_iface_init)
                         G_IMPLEMENT_INTERFACE(G_TYPE_STRING_BUILDER, g_register_operand_string_builder_iface_init)
                         G_IMPLEMENT_INTERFACE_IF_SYM(g_arch_operand_ui_get_type, g_register_operand_ui_arch_operand_ui_iface_init));
 
@@ -187,7 +187,7 @@ static void g_register_operand_hashable_object_iface_init(GHashableObjectInterfa
 *                                                                             *
 ******************************************************************************/
 
-static void g_register_operand_serializable_iface_init(GSerializableObjectInterface *iface)
+static void g_register_operand_serializable_object_iface_init(GSerializableObjectInterface *iface)
 {
     iface->load = g_register_operand_load;
     iface->store = g_register_operand_store;
-- 
cgit v0.11.2-87-g4458