From 91ad3ff600203217cdb631d8089d4777150bdd69 Mon Sep 17 00:00:00 2001
From: Cyrille Bagard <nocbos@gmail.com>
Date: Sat, 22 Mar 2025 09:20:25 +0100
Subject: Rename header.

---
 src/arch/operands/immediate-ui.c |  2 +-
 src/arch/operands/known-ui.c     |  2 +-
 src/arch/operands/register-ui.c  |  2 +-
 src/glibext/options/Makefile.am  |  4 +--
 src/glibext/options/asm.h        | 56 ++++++++++++++++++++++++++++++++++++++++
 src/glibext/options/disass.h     | 56 ----------------------------------------
 6 files changed, 61 insertions(+), 61 deletions(-)
 create mode 100644 src/glibext/options/asm.h
 delete mode 100644 src/glibext/options/disass.h

diff --git a/src/arch/operands/immediate-ui.c b/src/arch/operands/immediate-ui.c
index a6b4ae7..62058b3 100644
--- a/src/arch/operands/immediate-ui.c
+++ b/src/arch/operands/immediate-ui.c
@@ -30,7 +30,7 @@
 #include "immediate-int.h"
 #include "../../common/extstr.h"
 #include "../../glibext/tokenstyle.h"
-#include "../../glibext/options/disass.h"
+#include "../../glibext/options/asm.h"
 
 
 
diff --git a/src/arch/operands/known-ui.c b/src/arch/operands/known-ui.c
index b68e60c..9b7507a 100644
--- a/src/arch/operands/known-ui.c
+++ b/src/arch/operands/known-ui.c
@@ -26,7 +26,7 @@
 
 #include "known-int.h"
 #include "../../common/cpp.h"
-#include "../../glibext/options/disass.h"
+#include "../../glibext/options/asm.h"
 
 
 
diff --git a/src/arch/operands/register-ui.c b/src/arch/operands/register-ui.c
index c5469e1..513a24f 100644
--- a/src/arch/operands/register-ui.c
+++ b/src/arch/operands/register-ui.c
@@ -26,7 +26,7 @@
 
 #include "register.h"
 #include "../../glibext/strbuilder.h"
-#include "../../glibext/options/disass.h"
+#include "../../glibext/options/asm.h"
 
 
 
diff --git a/src/glibext/options/Makefile.am b/src/glibext/options/Makefile.am
index 19881cf..3f400c6 100644
--- a/src/glibext/options/Makefile.am
+++ b/src/glibext/options/Makefile.am
@@ -2,8 +2,8 @@
 noinst_LTLIBRARIES  = libglibextoptions.la
 
 
-libglibextoptions_la_SOURCES =			\
-	disass.h		\
+libglibextoptions_la_SOURCES =				\
+	asm.h									\
 	hex.h hex.c
 
 libglibextoptions_la_CFLAGS = $(TOOLKIT_CFLAGS)
diff --git a/src/glibext/options/asm.h b/src/glibext/options/asm.h
new file mode 100644
index 0000000..e916083
--- /dev/null
+++ b/src/glibext/options/asm.h
@@ -0,0 +1,56 @@
+
+/* Chrysalide - Outil d'analyse de fichiers binaires
+ * disass.h - prototypes pour les options de rendus de code désassemblé
+ *
+ * Copyright (C) 2025 Cyrille Bagard
+ *
+ *  This file is part of Chrysalide.
+ *
+ *  Chrysalide is free software; you can redistribute it and/or modify
+ *  it under the terms of the GNU General Public License as published by
+ *  the Free Software Foundation; either version 3 of the License, or
+ *  (at your option) any later version.
+ *
+ *  Chrysalide is distributed in the hope that it will be useful,
+ *  but WITHOUT ANY WARRANTY; without even the implied warranty of
+ *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+ *  GNU General Public License for more details.
+ *
+ *  You should have received a copy of the GNU General Public License
+ *  along with Chrysalide.  If not, see <http://www.gnu.org/licenses/>.
+ */
+
+
+#ifndef _GLIBEXT_OPTIONS_DISASS_H
+#define _GLIBEXT_OPTIONS_DISASS_H
+
+
+#include "../helpers.h"
+
+
+
+/* Liste des colonnes en options */
+typedef enum _DisassColumnOptions
+{
+    ACO_OFFSET,                             /* Position                    */
+
+    ACO_COUNT
+
+} DisassColumnOptions;
+
+
+#define ACO_ASSEMBLY (ACO_COUNT + 0)              /* Code pour assembleur        */
+
+
+#if 0
+#define G_TYPE_HEX_OPTIONS (g_hex_options_get_type())
+
+DECLARE_GTYPE(GHexOptions, g_hex_options, G, HEX_OPTIONS);
+
+
+/* Crée un groupe d'options pour le rendu d'hexadécimal. */
+GHexOptions *g_hex_options_new(void);
+#endif
+
+
+#endif  /* _GLIBEXT_OPTIONS_HEX_H */
diff --git a/src/glibext/options/disass.h b/src/glibext/options/disass.h
deleted file mode 100644
index e916083..0000000
--- a/src/glibext/options/disass.h
+++ /dev/null
@@ -1,56 +0,0 @@
-
-/* Chrysalide - Outil d'analyse de fichiers binaires
- * disass.h - prototypes pour les options de rendus de code désassemblé
- *
- * Copyright (C) 2025 Cyrille Bagard
- *
- *  This file is part of Chrysalide.
- *
- *  Chrysalide is free software; you can redistribute it and/or modify
- *  it under the terms of the GNU General Public License as published by
- *  the Free Software Foundation; either version 3 of the License, or
- *  (at your option) any later version.
- *
- *  Chrysalide is distributed in the hope that it will be useful,
- *  but WITHOUT ANY WARRANTY; without even the implied warranty of
- *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- *  GNU General Public License for more details.
- *
- *  You should have received a copy of the GNU General Public License
- *  along with Chrysalide.  If not, see <http://www.gnu.org/licenses/>.
- */
-
-
-#ifndef _GLIBEXT_OPTIONS_DISASS_H
-#define _GLIBEXT_OPTIONS_DISASS_H
-
-
-#include "../helpers.h"
-
-
-
-/* Liste des colonnes en options */
-typedef enum _DisassColumnOptions
-{
-    ACO_OFFSET,                             /* Position                    */
-
-    ACO_COUNT
-
-} DisassColumnOptions;
-
-
-#define ACO_ASSEMBLY (ACO_COUNT + 0)              /* Code pour assembleur        */
-
-
-#if 0
-#define G_TYPE_HEX_OPTIONS (g_hex_options_get_type())
-
-DECLARE_GTYPE(GHexOptions, g_hex_options, G, HEX_OPTIONS);
-
-
-/* Crée un groupe d'options pour le rendu d'hexadécimal. */
-GHexOptions *g_hex_options_new(void);
-#endif
-
-
-#endif  /* _GLIBEXT_OPTIONS_HEX_H */
-- 
cgit v0.11.2-87-g4458