From 51e4bf015e0bd0320f2a44bd1f97f1cd7e95a41d Mon Sep 17 00:00:00 2001
From: Cyrille Bagard <nocbos@gmail.com>
Date: Thu, 18 Aug 2022 21:07:48 +0200
Subject: Reduce the rendering concurrency between the GTK main loop and Python
 computation threads.

---
 plugins/python/cglimpse/panel.py | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

diff --git a/plugins/python/cglimpse/panel.py b/plugins/python/cglimpse/panel.py
index a195b0d..e2dc035 100644
--- a/plugins/python/cglimpse/panel.py
+++ b/plugins/python/cglimpse/panel.py
@@ -118,7 +118,8 @@ class CGlimpsePanel(PanelItem, UpdatablePanel):
 
         assert(uid == 0)
 
-        self.switch_to_updating_mask()
+        # Reduce the rendering concurrency between the GTK main loop and this thread
+        #self.switch_to_updating_mask()
 
 
     def _process(self, uid, status, id, data):
@@ -137,7 +138,8 @@ class CGlimpsePanel(PanelItem, UpdatablePanel):
 
         assert(uid == 0)
 
-        self.switch_to_updated_content()
+        # Reduce the rendering concurrency between the GTK main loop and this thread
+        # self.switch_to_updated_content()
 
 
     def _clean_data(self, uid, data):
-- 
cgit v0.11.2-87-g4458