From cd59150b26173fc4caa44b604d9e0989de331b3d Mon Sep 17 00:00:00 2001
From: Cyrille Bagard <nocbos@gmail.com>
Date: Fri, 25 Dec 2020 11:01:07 +0100
Subject: Taken non binary content into account for the glimpse panel.

---
 plugins/python/cglimpse/panel.py | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/plugins/python/cglimpse/panel.py b/plugins/python/cglimpse/panel.py
index 2fd3c7f..2245e3a 100644
--- a/plugins/python/cglimpse/panel.py
+++ b/plugins/python/cglimpse/panel.py
@@ -44,7 +44,7 @@ class CGlimpsePanel(PanelItem, UpdatablePanel):
     def _change_content(self, old, new):
         """Get notified about a LoadedContent change."""
 
-        self._content = new.content
+        self._content = new.content if new else None
 
         combo = self._builder.get_object('method_sel')
         self._on_method_changed(combo)
-- 
cgit v0.11.2-87-g4458