From 1970b15efeac7efcdc37ebcf98bb87f2d838d64e Mon Sep 17 00:00:00 2001
From: Cyrille Bagard <nocbos@gmail.com>
Date: Sat, 23 Nov 2024 23:33:50 +0100
Subject: Do not forget to save binary portion build parameters.

---
 src/glibext/portion.c | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/src/glibext/portion.c b/src/glibext/portion.c
index e5604b6..096a39d 100644
--- a/src/glibext/portion.c
+++ b/src/glibext/portion.c
@@ -202,6 +202,9 @@ GBinaryPortion *g_binary_portion_new(const vmpa2t *addr, phys_t size)
 
     result = g_object_new(G_TYPE_BINARY_PORTION, NULL);
 
+    if (!g_binary_portion_create(result, addr, size))
+        g_clear_object(&result);
+
     return result;
 
 }
-- 
cgit v0.11.2-87-g4458