From 9ac491cba6aa35959fa1ffdb9ce979060f5f6b26 Mon Sep 17 00:00:00 2001
From: Cyrille Bagard <nocbos@gmail.com>
Date: Sun, 14 Feb 2021 20:33:30 +0100
Subject: Delete a very old and unused plugin.

---
 plugins/stackvars/Makefile.am |  24 ----
 plugins/stackvars/operand.c   | 168 ------------------------
 plugins/stackvars/operand.h   |  60 ---------
 plugins/stackvars/stackvars.c | 291 ------------------------------------------
 plugins/stackvars/stackvars.h |  49 -------
 5 files changed, 592 deletions(-)
 delete mode 100644 plugins/stackvars/Makefile.am
 delete mode 100644 plugins/stackvars/operand.c
 delete mode 100644 plugins/stackvars/operand.h
 delete mode 100644 plugins/stackvars/stackvars.c
 delete mode 100644 plugins/stackvars/stackvars.h

diff --git a/plugins/stackvars/Makefile.am b/plugins/stackvars/Makefile.am
deleted file mode 100644
index 286f154..0000000
--- a/plugins/stackvars/Makefile.am
+++ /dev/null
@@ -1,24 +0,0 @@
-
-lib_LTLIBRARIES = libstackvars.la
-
-libdir = $(pluginslibdir)
-
-
-libstackvars_la_SOURCES =				\
-	operand.h operand.c					\
-	stackvars.h stackvars.c
-
-libstackvars_la_CFLAGS = $(AM_CFLAGS)
-
-libstackvars_la_LDFLAGS =					\
-	-L$(top_srcdir)/src/.libs -lchrysacore
-
-
-devdir = $(includedir)/chrysalide/$(subdir)
-
-dev_HEADERS = $(libstackvars_la_SOURCES:%c=)
-
-
-AM_CPPFLAGS = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) -I$(top_srcdir)/src
-
-AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
diff --git a/plugins/stackvars/operand.c b/plugins/stackvars/operand.c
deleted file mode 100644
index ecc3c4d..0000000
--- a/plugins/stackvars/operand.c
+++ /dev/null
@@ -1,168 +0,0 @@
-
-/* Chrysalide - Outil d'analyse de fichiers binaires
- * operand.c - opérandes de substitution pour variables
- *
- * Copyright (C) 2009-2018 Cyrille Bagard
- *
- *  This file is part of Chrysalide.
- *
- *  Chrysalide is free software; you can redistribute it and/or modify
- *  it under the terms of the GNU General Public License as published by
- *  the Free Software Foundation; either version 3 of the License, or
- *  (at your option) any later version.
- *
- *  Chrysalide is distributed in the hope that it will be useful,
- *  but WITHOUT ANY WARRANTY; without even the implied warranty of
- *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- *  GNU General Public License for more details.
- *
- *  You should have received a copy of the GNU General Public License
- *  along with Chrysalide.  If not, see <http://www.gnu.org/licenses/>.
- */
-
-
-#include "operand.h"
-
-
-#include <stdio.h>
-#include <string.h>
-
-
-#include <arch/operand-int.h>
-
-
-
-/* Définition d'un opérande de substitution pour variable de pile (instance) */
-struct _GStackVarOperand
-{
-    GArchOperand parent;                    /* Instance parente            */
-
-    const GBinRoutine *routine;             /* Routine d'appartenance      */
-    const GX86ModRMOperand *child;          /* Opérand d'origine substitué */
-
-};
-
-
-/* Définition d'un opérande de substitution pour variable de pile (classe) */
-struct _GStackVarOperandClass
-{
-    GArchOperandClass parent;               /* Classe parente              */
-
-};
-
-
-/* Initialise la classe des opérandes de substitution. */
-static void g_stack_var_operand_class_init(GStackVarOperandClass *);
-
-/* Initialise l'instande d'un opérandes de substitution. */
-static void g_stack_var_operand_init(GStackVarOperand *);
-
-
-
-/* Indique le type défini pour un opérande de substitution pour variable de pile. */
-G_DEFINE_TYPE(GStackVarOperand, g_stack_var_operand, G_TYPE_ARCH_OPERAND);
-
-
-/******************************************************************************
-*                                                                             *
-*  Paramètres  : klass = classe à initialiser.                                *
-*                                                                             *
-*  Description : Initialise la classe des opérandes de substitution.          *
-*                                                                             *
-*  Retour      : -                                                            *
-*                                                                             *
-*  Remarques   : -                                                            *
-*                                                                             *
-******************************************************************************/
-
-static void g_stack_var_operand_class_init(GStackVarOperandClass *klass)
-{
-
-}
-
-
-/******************************************************************************
-*                                                                             *
-*  Paramètres  : operand = instance à initialiser.                            *
-*                                                                             *
-*  Description : Initialise l'instande d'un opérandes de substitution.        *
-*                                                                             *
-*  Retour      : -                                                            *
-*                                                                             *
-*  Remarques   : -                                                            *
-*                                                                             *
-******************************************************************************/
-
-static void g_stack_var_operand_init(GStackVarOperand *operand)
-{
-
-}
-
-
-/******************************************************************************
-*                                                                             *
-*  Paramètres  : routine = routine d'appatenance de l'opérande.               *
-*                child   = opérande d'origine à substituer.                   *
-*                                                                             *
-*  Description : Crée un opérande de substitution pour variable de pile.      *
-*                                                                             *
-*  Retour      : Instruction mise en place.                                   *
-*                                                                             *
-*  Remarques   : -                                                            *
-*                                                                             *
-******************************************************************************/
-
-GArchOperand *g_stack_var_operand_new(const GBinRoutine *routine, const GX86ModRMOperand *child)
-{
-    GStackVarOperand *result;               /* Opérande à retourner        */
-
-    result = g_object_new(G_TYPE_STACK_VAR_OPERAND, NULL);
-
-    result->routine = routine;
-    result->child = child;
-
-    return G_ARCH_OPERAND(result);
-
-}
-
-#if 0
-/******************************************************************************
-*                                                                             *
-*  Paramètres  : operand = opérande à transcrire.                             *
-*                format = format du binaire manipulé.                         *
-*                buffer = zone de texte à venir compléter.                    *
-*                iter   = point d'insertion du nouveau texte.                 *
-*                                                                             *
-*  Description : Ajoute à un texte GTK le contenu d'un opérande.              *
-*                                                                             *
-*  Retour      : -                                                            *
-*                                                                             *
-*  Remarques   : -                                                            *
-*                                                                             *
-******************************************************************************/
-
-static void g_stack_var_operand_add_to_gtk_buffer(const GStackVarOperand *operand, const GExeFormat *format, GtkTextBuffer *buffer, GtkTextIter *iter)
-{
-    const GImmOperand *displacement;        /* Décalage supplémentaire     */
-    size_t value;                           /* Position dans la pile       */
-    bool negative;                          /* Direction dans la pile      */
-    size_t index;                           /* Indice de la variable       */
-    char name[32];                          /* Nom de la variable          */
-
-    displacement = g_x86_mod_rm_operand_get_displacement(operand->child);
-    g_imm_operand_to_size_t(displacement, &value, &negative);
-
-    g_content_exporter_insert_with_gtk_tag(G_CONTENT_EXPORTER(operand), buffer, iter,
-                                           "[", 1, RTT_HOOK);
-
-    index = g_binary_routine_get_var_index_from_offset(operand->routine, value, negative);
-    snprintf(name, 32, "%s%u", negative ? "local" : "arg", index);
-
-    g_content_exporter_insert_with_gtk_tag(G_CONTENT_EXPORTER(operand), buffer, iter,
-                                           name, strlen(name), RTT_VAR_NAME);
-
-    g_content_exporter_insert_with_gtk_tag(G_CONTENT_EXPORTER(operand), buffer, iter,
-                                           "]", 1, RTT_HOOK);
-
-}
-#endif
diff --git a/plugins/stackvars/operand.h b/plugins/stackvars/operand.h
deleted file mode 100644
index 299a2ed..0000000
--- a/plugins/stackvars/operand.h
+++ /dev/null
@@ -1,60 +0,0 @@
-
-/* Chrysalide - Outil d'analyse de fichiers binaires
- * operand.h - prototypes pour les opérandes de substitution pour variables
- *
- * Copyright (C) 2009-2018 Cyrille Bagard
- *
- *  This file is part of Chrysalide.
- *
- *  Chrysalide is free software; you can redistribute it and/or modify
- *  it under the terms of the GNU General Public License as published by
- *  the Free Software Foundation; either version 3 of the License, or
- *  (at your option) any later version.
- *
- *  Chrysalide is distributed in the hope that it will be useful,
- *  but WITHOUT ANY WARRANTY; without even the implied warranty of
- *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- *  GNU General Public License for more details.
- *
- *  You should have received a copy of the GNU General Public License
- *  along with Chrysalide.  If not, see <http://www.gnu.org/licenses/>.
- */
-
-
-#ifndef _PLUGINS_STACKVARS_OPERAND_H
-#define _PLUGINS_STACKVARS_OPERAND_H
-
-
-#include <glib-object.h>
-#include <stdbool.h>
-
-
-#include <analysis/routine.h>
-#include <arch/x86/operand.h>
-
-
-
-#define G_TYPE_STACK_VAR_OPERAND            g_stack_var_operand_get_type()
-#define G_STACK_VAR_OPERAND(obj)            (G_TYPE_CHECK_INSTANCE_CAST((obj), G_TYPE_STACK_VAR_OPERAND, GStackVarOperand))
-#define G_IS_STACK_VAR_OPERAND(obj)         (G_TYPE_CHECK_INSTANCE_TYPE((obj), G_TYPE_STACK_VAR_OPERAND))
-#define G_STACK_VAR_OPERAND_CLASS(klass)    (G_TYPE_CHECK_CLASS_CAST((klass), G_TYPE_STACK_VAR_OPERAND, GStackVarOperandClass))
-#define G_IS_STACK_VAR_OPERAND_CLASS(klass) (G_TYPE_CHECK_CLASS_TYPE((klass), G_TYPE_STACK_VAR_OPERAND))
-#define G_STACK_VAR_OPERAND_GET_CLASS(obj)  (G_TYPE_INSTANCE_GET_CLASS((obj), G_TYPE_STACK_VAR_OPERAND, GStackVarOperandClass))
-
-
-/* Définition d'un opérande de substitution pour variable de pile (instance) */
-typedef struct _GStackVarOperand GStackVarOperand;
-
-/* Définition d'un opérande de substitution pour variable de pile (classe) */
-typedef struct _GStackVarOperandClass GStackVarOperandClass;
-
-
-/* Indique le type défini pour un opérande de substitution pour variable de pile. */
-GType g_stack_var_operand_get_type(void);
-
-/* Crée un opérande de substitution pour variable de pile. */
-GArchOperand *g_stack_var_operand_new(const GBinRoutine *, const GX86ModRMOperand *);
-
-
-
-#endif  /* _PLUGINS_STACKVARS_OPERAND_H */
diff --git a/plugins/stackvars/stackvars.c b/plugins/stackvars/stackvars.c
deleted file mode 100644
index d7364c4..0000000
--- a/plugins/stackvars/stackvars.c
+++ /dev/null
@@ -1,291 +0,0 @@
-
-/* Chrysalide - Outil d'analyse de fichiers binaires
- * stackvars.c - substitution des emplacements de pile par des variables
- *
- * Copyright (C) 2009-2018 Cyrille Bagard
- *
- *  This file is part of Chrysalide.
- *
- *  Chrysalide is free software; you can redistribute it and/or modify
- *  it under the terms of the GNU General Public License as published by
- *  the Free Software Foundation; either version 3 of the License, or
- *  (at your option) any later version.
- *
- *  Chrysalide is distributed in the hope that it will be useful,
- *  but WITHOUT ANY WARRANTY; without even the implied warranty of
- *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- *  GNU General Public License for more details.
- *
- *  You should have received a copy of the GNU General Public License
- *  along with Chrysalide.  If not, see <http://www.gnu.org/licenses/>.
- */
-
-
-#include "stackvars.h"
-
-#if 0
-#include <analysis/routine.h>
-#include <arch/x86/operand.h>
-#include <format/executable.h>
-#include <format/format.h>
-
-
-#include "operand.h"
-
-
-
-/* Effectue tous les remplacements possibles dans une routine. */
-static bool replace_stack_vars_in_routine(GBinRoutine *, GRenderingLine *);
-
-/* Effectue d'éventuels remplacements dans une instruction. */
-static bool replace_stack_vars_in_instruction(GArchInstruction *, GBinRoutine *, bool);
-
-/* Effectue d'éventuels remplacements dans un opérande. */
-static bool replace_stack_var_in_operand(const GArchOperand *, GBinRoutine *, bool, GArchOperand **);
-
-
-
-/******************************************************************************
-*                                                                             *
-*  Paramètres  : ref = espace de référencement global.                        *
-*                                                                             *
-*  Description : Initialise le greffon pour les bornes de routine.            *
-*                                                                             *
-*  Retour      : true.                                                        *
-*                                                                             *
-*  Remarques   : -                                                            *
-*                                                                             *
-******************************************************************************/
-
-G_MODULE_EXPORT bool init_plugin(GObject *ref)
-{
-    return true;
-
-}
-
-
-/******************************************************************************
-*                                                                             *
-*  Paramètres  : -                                                            *
-*                                                                             *
-*  Description : Fournit une indication sur le type d'opération(s) menée(s).  *
-*                                                                             *
-*  Retour      : Description d'une action.                                    *
-*                                                                             *
-*  Remarques   : -                                                            *
-*                                                                             *
-******************************************************************************/
-
-G_MODULE_EXPORT PluginAction get_plugin_action(void)
-{
-    return PGA_CODE_PROCESS;
-
-}
-
-
-/******************************************************************************
-*                                                                             *
-*  Paramètres  : binary = représentation binaire à traiter.                   *
-*                action = action attendue.                                    *
-*                                                                             *
-*  Description : Exécute une action définie sur un binaire chargé.            *
-*                                                                             *
-*  Retour      : true si une action a été menée, false sinon.                 *
-*                                                                             *
-*  Remarques   : -                                                            *
-*                                                                             *
-******************************************************************************/
-
-G_MODULE_EXPORT bool execute_action_on_binary(GLoadedBinary *binary, PluginAction action)
-{
-    bool result;                            /* Bilan à retourner           */
-    GRenderingLine *lines;                  /* Lignes de rendu             */
-    GExeFormat *format;                     /* Format du binaire fourni    */
-    GBinRoutine **routines;                 /* Liste des routines trouvées */
-    size_t routines_count;                  /* Nombre de ces routines      */
-    size_t i;                               /* Boucle de parcours          */
-
-    result = false;
-
-    lines = g_loaded_binary_get_lines(binary);
-
-    format = g_loaded_binary_get_format(binary);
-    routines = NULL;//g_binary_format_get_routines(G_BIN_FORMAT(format), &routines_count);
-    routines_count = 0; //
-
-    for (i = 0; i < routines_count; i++)
-        result |= replace_stack_vars_in_routine(routines[i], lines);
-
-    g_object_unref(G_OBJECT(format));
-
-    return result;
-
-}
-
-
-/******************************************************************************
-*                                                                             *
-*  Paramètres  : routine = routine dont le code est à analyser.               *
-*                lines   = ensemble des lignes de rendu.                      *
-*                                                                             *
-*  Description : Effectue tous les remplacements possibles dans une routine.  *
-*                                                                             *
-*  Retour      : true si une action a été menée, false sinon.                 *
-*                                                                             *
-*  Remarques   : -                                                            *
-*                                                                             *
-******************************************************************************/
-
-static bool replace_stack_vars_in_routine(GBinRoutine *routine, GRenderingLine *lines)
-{
-    bool result;                            /* Bilan à retourner           */
-    const mrange_t *range;                  /* Emplacement du symbole      */
-    vmpa_t start;                           /* Adresse de début de routine */
-    vmpa_t end;                             /* Adresse de fin de routine   */
-    GRenderingLine *iter;                   /* Boucle de parcours          */
-    GArchInstruction *instr;                /* Instruction à ausculter     */
-
-    result = false;
-
-    range = g_binary_symbol_get_range(G_BIN_SYMBOL(routine));
-
-    start = get_mrange_addr(range)->virtual;
-    end = start + get_mrange_length(range);
-
-    for (iter = g_rendering_line_find_by_address(lines, NULL, start);
-         iter != NULL && get_rendering_line_address(iter) < end;
-         iter = g_rendering_line_get_next_iter(lines, iter, NULL))
-    {
-        if (!G_IS_CODE_LINE(iter)) continue;
-
-        instr = g_code_line_get_instruction(G_CODE_LINE(iter));
-
-        result |= replace_stack_vars_in_instruction(instr, routine, true);
-
-    }
-
-    if (!result) return false;
-    else result = false;
-
-    for (iter = g_rendering_line_find_by_address(lines, NULL, start);
-         iter != NULL && get_rendering_line_address(iter) < end;
-         iter = g_rendering_line_get_next_iter(lines, iter, NULL))
-    {
-        if (!G_IS_CODE_LINE(iter)) continue;
-
-        instr = g_code_line_get_instruction(G_CODE_LINE(iter));
-
-        result |= replace_stack_vars_in_instruction(instr, routine, false);
-
-    }
-
-    return result;
-
-}
-
-
-/******************************************************************************
-*                                                                             *
-*  Paramètres  : instr   = instruction dont le contenu peut être modifié.     *
-*                routine = routine contenant l'instruction analysée.          *
-*                dryrun  = mode enregistrement ou remplacement ?              *
-*                                                                             *
-*  Description : Effectue d'éventuels remplacements dans une instruction.     *
-*                                                                             *
-*  Retour      : true si une action a été menée, false sinon.                 *
-*                                                                             *
-*  Remarques   : -                                                            *
-*                                                                             *
-******************************************************************************/
-
-static bool replace_stack_vars_in_instruction(GArchInstruction *instr, GBinRoutine *routine, bool dryrun)
-{
-    bool result;                            /* Bilan à renvoyer            */
-    GArchOperand *new;                      /* Opérande d'encapsulation    */
-    size_t opcount;                         /* Nombre d'opérandes          */
-    size_t i;                               /* Boucle de parcours          */
-    const GArchOperand *operand;            /* Opérande de l'instruction   */
-
-    result = false;
-    new = NULL;     /* Pour GCC */
-
-    g_arch_instruction_lock_operands(instr);
-
-    opcount = _g_arch_instruction_count_operands(instr);
-
-    for (i = 0; i < opcount; i++)
-    {
-        operand = _g_arch_instruction_get_operand(instr, i);
-        result = replace_stack_var_in_operand(operand, routine, dryrun, &new);
-
-        if (!dryrun && result)
-        {
-            _g_arch_instruction_replace_operand(instr, operand, new);
-
-            result = true;
-
-        }
-
-        g_object_unref(G_OBJECT(operand));
-
-    }
-
-    g_arch_instruction_unlock_operands(instr);
-
-    return result;
-
-}
-
-
-/******************************************************************************
-*                                                                             *
-*  Paramètres  : operand = opérande dont le contenu est à analyser.           *
-*                routine = routine contenant l'opérande analysé.              *
-*                dryrun  = mode enregistrement ou remplacement ?              *
-*                new     = éventuelle nouvelle encapsulation créée.           *
-*                                                                             *
-*  Description : Effectue d'éventuels remplacements dans un opérande.         *
-*                                                                             *
-*  Retour      : Nouvel opérande de remplacemet ou NULL si aucun besoin.      *
-*                                                                             *
-*  Remarques   : -                                                            *
-*                                                                             *
-******************************************************************************/
-
-static bool replace_stack_var_in_operand(const GArchOperand *operand, GBinRoutine *routine, bool dryrun, GArchOperand **new)
-{
-    bool result;                            /* Bilan à retourner           */
-    GX86ModRMOperand *modrm;                /* Autre version de l'opérande */
-    uint8_t scale;                          /* Puissance de deux           */
-    const GX86Register *index;              /* Registre servant d'indice   */
-    const GX86Register *base;               /* Registre de base            */
-    const GImmOperand *displacement;        /* Décalage supplémentaire     */
-    size_t value;                           /* Position dans la pile       */
-    bool negative;                          /* Direction dans la pile      */
-
-    result = false;
-
-    if (G_IS_X86_MOD_RM_OPERAND(operand))
-    {
-        modrm = G_X86_MOD_RM_OPERAND(operand);
-
-        g_x86_mod_rm_operand_get_scale_and_index(modrm, &scale, &index);
-        base = g_x86_mod_rm_operand_get_base(modrm);
-        displacement = g_x86_mod_rm_operand_get_displacement(modrm);
-
-        if (scale == 0 && g_x86_register_is_base_pointer(index) && base == NULL
-            && g_imm_operand_to_size_t(displacement, &value, &negative))
-        {
-            if (dryrun) g_binary_routine_register_if_needed(routine, value, negative);
-            else *new = g_stack_var_operand_new(routine, modrm);
-
-            result = true;
-
-        }
-
-    }
-
-    return result;
-
-}
-#endif
diff --git a/plugins/stackvars/stackvars.h b/plugins/stackvars/stackvars.h
deleted file mode 100644
index a1bb003..0000000
--- a/plugins/stackvars/stackvars.h
+++ /dev/null
@@ -1,49 +0,0 @@
-
-/* Chrysalide - Outil d'analyse de fichiers binaires
- * stackvars.h - prototypes pour la substitution des emplacements de pile par des variables
- *
- * Copyright (C) 2009-2018 Cyrille Bagard
- *
- *  This file is part of Chrysalide.
- *
- *  Chrysalide is free software; you can redistribute it and/or modify
- *  it under the terms of the GNU General Public License as published by
- *  the Free Software Foundation; either version 3 of the License, or
- *  (at your option) any later version.
- *
- *  Chrysalide is distributed in the hope that it will be useful,
- *  but WITHOUT ANY WARRANTY; without even the implied warranty of
- *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- *  GNU General Public License for more details.
- *
- *  You should have received a copy of the GNU General Public License
- *  along with Chrysalide.  If not, see <http://www.gnu.org/licenses/>.
- */
-
-
-#ifndef _PLUGINS_STACKVARS_STACKVARS_H
-#define _PLUGINS_STACKVARS_STACKVARS_H
-
-#if 0
-#include <glib-object.h>
-#include <gmodule.h>
-#include <stdbool.h>
-
-
-#include <analysis/binary.h>
-#include <plugins/plugin-def.h>
-
-
-
-/* Initialise le greffon pour les bornes de routine. */
-G_MODULE_EXPORT bool init_plugin(GObject *);
-
-/* Fournit une indication sur le type d'opération(s) menée(s). */
-G_MODULE_EXPORT PluginAction get_plugin_action(void);
-
-/* Exécute une action définie sur un binaire chargé. */
-G_MODULE_EXPORT bool execute_action_on_binary(GLoadedBinary *, PluginAction);
-#endif
-
-
-#endif  /* _PLUGINS_STACKVARS_STACKVARS_H */
-- 
cgit v0.11.2-87-g4458