summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2010-05-18 23:35:50 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2010-05-18 23:35:50 (GMT)
commitadd611caeebe4c504652f99895c30846af239339 (patch)
tree340c86fb0f937a641d791803e4ebf5e93e84ab1a /Makefile.am
parent7adb4243ad629554e496de173977721a8a5d0110 (diff)
Displayed the about window.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@157 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a28f09b..13a6314 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,15 @@
-EXTRA_DIST = config.rpath config.rpath config.rpath ChangeLog
+BUILT_SOURCES = revision.h
+
+.svn:
+ @[ -d $@ ] || touch $@
+
+revision.h: .svn
+ @nb=`svn log . -l 1 -q | grep r | cut -d ' ' -f 1 | tr -d 'r'` ; \
+ sed -i "s/#define REVISION .*$$/#define REVISION $$nb/" $@ ; \
+ [ -f $< ] && rm $<
+
+EXTRA_DIST = config.rpath config.rpath config.rpath config.rpath ChangeLog
SUBDIRS = pixmaps src plugins