summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2025-01-27 22:55:28 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2025-01-27 22:55:28 (GMT)
commitd9e58809802a6068fa8794735c42ea2f8e96ff10 (patch)
treeefa1776c1c03bfcd94c34950fac68ab32289b34c /configure.ac
parent34a6fb58fc1b8923830e0260c57f2ba90a499a48 (diff)
Fix the configuration for the JSON-GLib library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2ff719a..73a54e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -241,6 +241,10 @@ AC_ARG_ENABLE([magic-support],
AS_HELP_STRING([--disable-magic-support], [disable magic number recognition [default=no]]),
[], [enable_magic_support=yes])
+AC_ARG_ENABLE([jsonglib-support],
+ AS_HELP_STRING([--disable-jsonglib-support], [disable jsonglib support [default=no]]),
+ [], [enable_jsonglib_support=yes])
+
AC_ARG_ENABLE([python-bindings],
AS_HELP_STRING([--disable-python-bindings], [disable Python bindings [default=no]]),
[], [enable_python_bindings=yes])
@@ -600,8 +604,6 @@ if test "x$BUILD_JSONGLIB_SUPPORT_TRUE" = "x"; then
CPPFLAGS="$CPPFLAGS -DINCLUDE_JSONGLIB_SUPPORT"
fi
-curl
-
PKG_CHECK_MODULES(LIBJSONGLIB,json-glib-1.0 >= 1.6.6,[libjsonglib_found=yes],[libjsonglib_found=no])
@@ -907,7 +909,7 @@ echo The client URL library....................... : $libcurl_version
echo The YAML support library..................... : $libyaml_version
echo The magic number recognition library......... : $libmagic_version
echo The high-performance matching library........ : $libhs_version
-echo The JSON Parser for GLib library............. : $libjsonglib_version
+echo The JSON Parser for the GLib library......... : $libjsonglib_version
echo
echo Available Python programming language........ : $python3_version