summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2009-06-25 00:34:22 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2009-06-25 00:34:22 (GMT)
commitf2696c85e502e36a529a1d8ee3d209498ac2c0e9 (patch)
tree3d8ffe28a730d32c98e8d048b99f67b7856acec9 /configure.ac
parent23c7cd436e2ec980a68e6d12a6d8a750e357763c (diff)
Used Graphviz library for building graphs (first attempt).
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@80 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e533967..350cea1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -205,6 +205,19 @@ AC_SUBST(LIBVTE_CFLAGS)
AC_SUBST(LIBVTE_LIBS)
+#--- Checks for libvte
+
+PKG_CHECK_MODULES(LIBGRAPH,libgvc >= 0.20.2,[libgraph_found=yes],[libgraph_found=no])
+
+if test "$libgraph_found" = "yes"; then
+ libgraph_version=`pkg-config libgvc --modversion`
+else
+ libgraph_version='-'
+fi
+
+AC_SUBST(LIBGRAPH_CFLAGS)
+AC_SUBST(LIBGRAPH_LIBS)
+
############################################################
# Outputting files
@@ -231,6 +244,7 @@ AC_CONFIG_FILES([Makefile
src/format/java/Makefile
src/format/mangling/Makefile
src/format/pe/Makefile
+ src/graph/Makefile
src/gtkext/Makefile
src/panel/Makefile
src/plugins/Makefile
@@ -246,6 +260,7 @@ echo $PACKAGE $VERSION
echo
echo The GNU Image Manipulation Program Toolkit... : $libgtk_version
echo The XML C parser and toolkit of Gnome........ : $libxml_version
+echo The graph library from Graphviz.............. : $libgraph_version
echo
echo Print debugging messages..................... : $enable_debug