summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2012-12-21 12:54:17 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2012-12-21 12:54:17 (GMT)
commit0cfcbee3c536ac6d11ec806d47ce4c136f695697 (patch)
treeffe4164a1337922e66c2ed024eeb6d407ab76d59 /configure.ac
parentcf9ea46a796000f0252bb7d80c0ac0fb170e156a (diff)
Unloaded loaded plugins and (started to) avoid memory leaks.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@307 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c1df58c..5658e46 100644
--- a/configure.ac
+++ b/configure.ac
@@ -188,8 +188,13 @@ AC_SUBST(LIBXML_LIBS)
#--- Checks for Python
-LIBPYTHON_CFLAGS=`python-config --cflags`
-LIBPYTHON_LIBS=`python-config --libs`
+if test "x$enable_debug" = "xyes"; then
+ LIBPYTHON_CFLAGS=`python-dbg-config --cflags`
+ LIBPYTHON_LIBS=`python-dbg-config --libs`
+else
+ LIBPYTHON_CFLAGS=`python-config --cflags`
+ LIBPYTHON_LIBS=`python-config --libs`
+fi
AC_SUBST(LIBPYTHON_CFLAGS)
AC_SUBST(LIBPYTHON_LIBS)