summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2009-03-14 17:01:36 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2009-03-14 17:01:36 (GMT)
commita2b767b244e03f00c6a987bbd9872796ed385f47 (patch)
treecd4f2f0c516948fad80493d1a7193b454f9153fc /configure.ac
parentc4231094c9c77c685371d726d28e65c0459486de (diff)
Turned off lots of warnings by using the _GNU_SOURCE compliance.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@54 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7a95ffd..1b7bdfa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -141,12 +141,18 @@ AC_SUBST(DEBUG_CFLAGS)
#-Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes
-WARNING_FLAGS="-D_ISOC99_SOURCE -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes"
+WARNING_FLAGS="-Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes"
#-Wcast-qual -Wconversion -Wsign-compare -Wdisabled-optimization
AC_SUBST(WARNING_FLAGS)
+# _XOPEN_SOURCE: strdup, snprintf
+# _ISOC99_SOURCE: INFINITY; NAN
+COMPLIANCE_FLAGS="-D_GNU_SOURCE"
+
+AC_SUBST(COMPLIANCE_FLAGS)
+
#--- Checks for GTK 2.0
PKG_CHECK_MODULES(LIBGTK,gtk+-2.0 >= 2.4.3,[libgtk_found=yes],[libgtk_found=no])