summaryrefslogtreecommitdiff
path: root/plugins/pyoida/debug/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2012-02-01 10:12:54 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2012-02-01 10:12:54 (GMT)
commit0c847f961a99d8e8012beecad27cf4318df1ff88 (patch)
treee73689b844184f272267ae54ac27a6e826410478 /plugins/pyoida/debug/Makefile.am
parent14e82ed268cb78d62bbba93357fede5ece5c4f7d (diff)
Provided a debug module for Python plugins using the PyGObject API.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@232 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'plugins/pyoida/debug/Makefile.am')
-rw-r--r--plugins/pyoida/debug/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/plugins/pyoida/debug/Makefile.am b/plugins/pyoida/debug/Makefile.am
new file mode 100644
index 0000000..4f01701
--- /dev/null
+++ b/plugins/pyoida/debug/Makefile.am
@@ -0,0 +1,17 @@
+
+noinst_LTLIBRARIES = libpyoidadebug.la
+
+libpyoidadebug_la_SOURCES = \
+ debugger.h debugger.c \
+ module.h module.c
+
+
+libpyoidadebug_la_LDFLAGS =
+
+
+INCLUDES = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBPYTHON_CFLAGS) $(LIBPYGOBJECT_CFLAGS) \
+ -I../../../src
+
+AM_CPPFLAGS =
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)