summaryrefslogtreecommitdiff
path: root/plugins/python/androperms/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2012-08-06 20:29:20 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2012-08-06 20:29:20 (GMT)
commitfc49e98dc2b3e0ae08a5874ecacaef046a0f3ec1 (patch)
treee121c5eb5dd0629554a498f8e1a1cce3fc0715b4 /plugins/python/androperms/Makefile.am
parentfacec716100f598a8694889274a4589c75c14722 (diff)
Saved progress toward the Android permissions display.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@258 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'plugins/python/androperms/Makefile.am')
-rw-r--r--plugins/python/androperms/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/plugins/python/androperms/Makefile.am b/plugins/python/androperms/Makefile.am
index 3d1755c..f44be3c 100644
--- a/plugins/python/androperms/Makefile.am
+++ b/plugins/python/androperms/Makefile.am
@@ -3,10 +3,18 @@ andropermsdir = $(datadir)/openida/plugins/python/androperms
androperms_DATA = \
__init__.py \
+ androperms.db \
androperms.py \
defs.py \
manifest.py \
+ panel.py \
parser.py \
reader.py \
stack.py \
string.py
+
+androperms.db:
+ @tmpzip=`tempfile` ; \
+ wget http://www.android-permissions.org/permissionmap.zip -O $$tmpzip ; \
+ unzip -p $$tmpzip permissionmap/APICalls.txt | tail -n +2 - > androperms.db ; \
+ rm $$tmpzip