summaryrefslogtreecommitdiff
path: root/src/arch/dalvik/opcodes/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2012-11-11 18:08:20 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2012-11-11 18:08:20 (GMT)
commit2e5d98e2367a90e5b258c30dc68e5981d1f63339 (patch)
treeb4ed9410b619af8f80585c27aba29d89b4543783 /src/arch/dalvik/opcodes/Makefile.am
parent85be5ab140bb90ca69e20323eb49999d8520af13 (diff)
Registered the remaining instructions for a full Dalvik opcodes support.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@281 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/arch/dalvik/opcodes/Makefile.am')
-rw-r--r--src/arch/dalvik/opcodes/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/arch/dalvik/opcodes/Makefile.am b/src/arch/dalvik/opcodes/Makefile.am
index 5e2432a..08de704 100644
--- a/src/arch/dalvik/opcodes/Makefile.am
+++ b/src/arch/dalvik/opcodes/Makefile.am
@@ -14,12 +14,16 @@ libarchdalvikopcodes_la_SOURCES = \
goto.c \
if.c \
iget.c \
+ instanceof.c \
invoke.c \
iput.c \
+ monitor.c \
move.c \
mul.c \
+ neg.c \
new.c \
nop.c \
+ not.c \
opcodes.h \
or.c \
rem.c \
@@ -31,6 +35,7 @@ libarchdalvikopcodes_la_SOURCES = \
sput.c \
sub.c \
switch.c \
+ throw.c \
to.c \
ushr.c \
xor.c