summaryrefslogtreecommitdiff
path: root/src/arch/instructions/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2025-04-01 00:05:16 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2025-04-01 00:05:16 (GMT)
commitbb7e4c5e6e4c51da0d9b1a33b571b0c64851c1a8 (patch)
tree4575210322bf6838f538a4f58967c0a2a0d9cabc /src/arch/instructions/Makefile.am
parent70ed4dc99c75c13797b41164959c753ffbc4572b (diff)
Restore most features of core instructions.gtk4
Diffstat (limited to 'src/arch/instructions/Makefile.am')
-rw-r--r--src/arch/instructions/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/arch/instructions/Makefile.am b/src/arch/instructions/Makefile.am
index 28cf90f..d6fc4bd 100644
--- a/src/arch/instructions/Makefile.am
+++ b/src/arch/instructions/Makefile.am
@@ -1,12 +1,19 @@
-noinst_LTLIBRARIES = libarchinstructions.la
+noinst_LTLIBRARIES = libarchinstructions.la libarchinstructionsui.la
libarchinstructions_la_SOURCES = \
+ raw-int.h \
raw.h raw.c \
undefined-int.h \
undefined.h undefined.c
-libarchinstructions_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS)
+libarchinstructions_la_CFLAGS = $(LIBGOBJ_CFLAGS)
+
+libarchinstructionsui_la_SOURCES = \
+ raw-ui.h raw-ui.c \
+ undefined-ui.h undefined-ui.c
+
+libarchinstructionsui_la_CFLAGS = $(LIBGTK4_CFLAGS)
devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)