summaryrefslogtreecommitdiff
path: root/src/arch/x86/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2008-10-27 20:00:09 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2008-10-27 20:00:09 (GMT)
commit2e5893f9261ba59e06fadcc6ddfa9a1253e286b3 (patch)
tree8197f6419812e7c36c28d6849ced3e37e8926539 /src/arch/x86/Makefile.am
parent197933fdf469ab9b8897b33c51809c128f1e3c03 (diff)
Extended the current opcode support (0x01, 0x72, 0x73, 0x88, 0xd3, 0xf7, 0xfc, 0xb6 and 0xbe).
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@38 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/arch/x86/Makefile.am')
-rw-r--r--src/arch/x86/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/arch/x86/Makefile.am b/src/arch/x86/Makefile.am
index 58ffaa8..42326c9 100644
--- a/src/arch/x86/Makefile.am
+++ b/src/arch/x86/Makefile.am
@@ -7,6 +7,7 @@ libarchx86_a_SOURCES = \
op_add.c \
op_and.c \
op_call.c \
+ op_cld.c \
op_cmp.c \
op_dec.c \
op_hlt.c \
@@ -15,9 +16,11 @@ libarchx86_a_SOURCES = \
op_jump.c \
op_lea.c \
op_leave.c \
- op_nop.c \
op_mov.c \
+ op_movsx.c \
op_movzx.c \
+ op_nop.c \
+ op_not.c \
op_or.c \
op_pop.c \
op_push.c \