summaryrefslogtreecommitdiff
path: root/src/arch/x86/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2012-10-18 00:28:06 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2012-10-18 00:28:06 (GMT)
commitf7d126acb7718d4a13ac64c0d71c7d019cc8c18c (patch)
treeb4b32237b99344beba8c03333972efb8f108a5cf /src/arch/x86/Makefile.am
parent2cfb66fcd5e8293d1dd689691bdc8c3517dd183a (diff)
Reorganized the code for the x86 architecture support.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@274 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/arch/x86/Makefile.am')
-rw-r--r--src/arch/x86/Makefile.am47
1 files changed, 4 insertions, 43 deletions
diff --git a/src/arch/x86/Makefile.am b/src/arch/x86/Makefile.am
index ff246c0..b7b72d6 100644
--- a/src/arch/x86/Makefile.am
+++ b/src/arch/x86/Makefile.am
@@ -3,52 +3,13 @@ noinst_LTLIBRARIES = libarchx86.la
libarchx86_la_SOURCES = \
instruction.h instruction.c \
- op_adc.c \
- op_add.c \
- op_and.c \
- op_arpl.c \
- op_call.c \
- op_cld.c \
- op_cmp.c \
- op_cmps.c \
- op_dec.c \
- op_hlt.c \
- op_inc.c \
- op_int.c \
- op_jump.c \
- op_lea.c \
- op_leave.c \
- op_mov.c \
- op_movs.c \
- op_movsx.c \
- op_movzx.c \
- op_mul.c \
- op_nop.c \
- op_not.c \
- op_or.c \
- op_pop.c \
- op_push.c \
- op_rcl.c \
- op_rcr.c \
- op_ret.c \
- op_rol.c \
- op_ror.c \
- op_sar.c \
- op_sbb.c \
- op_scas.c \
- op_set.c \
- op_shl.c \
- op_shr.c \
- op_stos.c \
- op_sub.c \
- op_test.c \
- op_xchg.c \
- op_xor.c \
- opcodes.h \
operand.h operand.c \
processor.h processor.c \
registers.h registers.c
+libarchx86_la_LIBADD = \
+ opcodes/libarchx86opcodes.la \
+ operands/libarchx86operands.la
libarchx86_la_CFLAGS = $(AM_CFLAGS)
@@ -60,4 +21,4 @@ AM_CPPFLAGS =
AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-SUBDIRS =
+SUBDIRS = opcodes operands