summaryrefslogtreecommitdiff
path: root/src/arch/x86/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2008-09-14 20:54:43 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2008-09-14 20:54:43 (GMT)
commit06cf576b280cbabb73a956161693a63ee846f57b (patch)
tree3ac4b32e869cc8aaa1d4b7429d7d4a12f9a8ae7f /src/arch/x86/Makefile.am
parentab1489b6a6ef1f09957f6f805f143fceb42f6a08 (diff)
Made the program able to disassemble a simple binary completely.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@30 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/arch/x86/Makefile.am')
-rw-r--r--src/arch/x86/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/arch/x86/Makefile.am b/src/arch/x86/Makefile.am
index b074f69..139bcde 100644
--- a/src/arch/x86/Makefile.am
+++ b/src/arch/x86/Makefile.am
@@ -7,10 +7,12 @@ libarchx86_a_SOURCES = \
op_add.c \
op_and.c \
op_call.c \
+ op_cmp.c \
op_dec.c \
op_hlt.c \
op_inc.c \
op_int.c \
+ op_jump.c \
op_lea.c \
op_leave.c \
op_nop.c \
@@ -19,6 +21,7 @@ libarchx86_a_SOURCES = \
op_pop.c \
op_push.c \
op_ret.c \
+ op_sar.c \
op_sbb.c \
op_sub.c \
op_test.c \