summaryrefslogtreecommitdiff
path: root/src/arch/x86/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2008-07-26 23:46:10 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2008-07-26 23:46:10 (GMT)
commitdbf4d1f93e54251568854bff0ebc9c84f60857f6 (patch)
tree72fa507ada7ba5b7351f711a7f16a8d3f7d32524 /src/arch/x86/Makefile.am
parentc4f9b35d4ccb5bb82c4927daddd34d7a828bff3c (diff)
Parsed x86 binary data and displayed the result.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@6 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/arch/x86/Makefile.am')
-rw-r--r--src/arch/x86/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/arch/x86/Makefile.am b/src/arch/x86/Makefile.am
new file mode 100644
index 0000000..6fe55c8
--- /dev/null
+++ b/src/arch/x86/Makefile.am
@@ -0,0 +1,20 @@
+
+lib_LIBRARIES = libarchx86.a
+
+libarchx86_a_SOURCES = \
+ instruction.h \
+ op_int.c \
+ opcodes.h \
+ processor.h processor.c
+
+libarchx86_a_CFLAGS = $(AM_CFLAGS)
+
+
+INCLUDES =
+
+AM_CPPFLAGS =
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS)
+
+
+SUBDIRS =