summaryrefslogtreecommitdiff
path: root/src/arch/x86/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2008-08-01 21:08:17 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2008-08-01 21:08:17 (GMT)
commitf0b80c6ab55ede4f8ab8ede757f1f8951512affa (patch)
tree7072841db027d421da1118f8021020a1b682de4f /src/arch/x86/Makefile.am
parent3786e818fdf8731dd6f310f0aaac75d431646160 (diff)
Handled the 'leave' and 'ret' opcodes.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@12 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/arch/x86/Makefile.am')
-rw-r--r--src/arch/x86/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/arch/x86/Makefile.am b/src/arch/x86/Makefile.am
index da03534..0a32def 100644
--- a/src/arch/x86/Makefile.am
+++ b/src/arch/x86/Makefile.am
@@ -8,10 +8,12 @@ libarchx86_a_SOURCES = \
op_hlt.c \
op_inc.c \
op_int.c \
+ op_leave.c \
op_nop.c \
op_mov.c \
op_pop.c \
op_push.c \
+ op_ret.c \
opcodes.h \
operand.h operand.c \
processor.h processor.c