summaryrefslogtreecommitdiff
path: root/src/arch/x86/operands/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2012-10-18 00:28:06 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2012-10-18 00:28:06 (GMT)
commitf7d126acb7718d4a13ac64c0d71c7d019cc8c18c (patch)
treeb4b32237b99344beba8c03333972efb8f108a5cf /src/arch/x86/operands/Makefile.am
parent2cfb66fcd5e8293d1dd689691bdc8c3517dd183a (diff)
Reorganized the code for the x86 architecture support.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@274 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/arch/x86/operands/Makefile.am')
-rw-r--r--src/arch/x86/operands/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/arch/x86/operands/Makefile.am b/src/arch/x86/operands/Makefile.am
new file mode 100644
index 0000000..ac48667
--- /dev/null
+++ b/src/arch/x86/operands/Makefile.am
@@ -0,0 +1,21 @@
+
+noinst_LTLIBRARIES = libarchx86operands.la
+
+libarchx86operands_la_SOURCES = \
+ data.h data.c \
+ modrm.h modrm.c \
+ moffs.h moffs.c \
+ register.h register.c \
+ relative.h relative.c
+
+libarchx86_la_CFLAGS = $(AM_CFLAGS)
+
+
+INCLUDES = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
+
+AM_CPPFLAGS =
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
+
+
+SUBDIRS =