summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2024-08-25 16:55:24 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2024-08-25 16:55:24 (GMT)
commit41dcf8a45d61108fef1f545ecdee5d79d8135089 (patch)
tree358c8a9b85e3d582ebe8e0f68c208785a4801517 /src/common/Makefile.am
parentf505830e800e4061d6e57c2b0769f956e70a2d84 (diff)
Restore an improved cURL support.
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 83c754c..24929e7 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -62,10 +62,24 @@ libcommon4_la_SOURCES = \
pathname.h pathname.c \
shuffle.h shuffle.c \
sort.h sort.c \
+ szbin.h \
xdg.h xdg.c
+if BUILD_CURL_SUPPORT
+
+libcommon4_la_SOURCES += \
+ curl.h curl.c
+
+endif
+
libcommon4_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBSSL_CFLAGS)
+if BUILD_CURL_SUPPORT
+
+libcommon4_la_CFLAGS += $(LIBCURL_CFLAGS)
+
+endif
+
devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)