summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2024-08-25 17:03:08 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2024-08-25 17:03:08 (GMT)
commita0532508524a37444d15b878c5e494cd348b0cae (patch)
tree8b3d06e52123e953cd937501a7ea5d0d46461a6e /src/common/Makefile.am
parent41dcf8a45d61108fef1f545ecdee5d79d8135089 (diff)
Include support for the JSON format.
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 24929e7..7f0fe4e 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -56,6 +56,7 @@ libcommon4_la_SOURCES = \
extstr.h extstr.c \
fnv1a.h fnv1a.c \
io.h io.c \
+ json.h json.c \
leb128.h leb128.c \
macros.h \
packed.h packed.c \
@@ -72,7 +73,7 @@ libcommon4_la_SOURCES += \
endif
-libcommon4_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBSSL_CFLAGS)
+libcommon4_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBSSL_CFLAGS) $(LIBJSONGLIB_CFLAGS)
if BUILD_CURL_SUPPORT