summaryrefslogtreecommitdiff
path: root/src/common/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2024-05-14 20:00:12 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2024-05-14 20:00:12 (GMT)
commited57185faa4d7a53d953cf74a6f8626f44ce9b75 (patch)
treef34cb583e8c0d054676adb9f1da826aa92479d11 /src/common/Makefile.am
parente9f10d8fe1c5e9f8a70801c1cd4d3d342e290f15 (diff)
Restore some logging facilities with automatic switch to the GUI.
Diffstat (limited to 'src/common/Makefile.am')
-rw-r--r--src/common/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/common/Makefile.am b/src/common/Makefile.am
index 1a8f8c4..53d3627 100644
--- a/src/common/Makefile.am
+++ b/src/common/Makefile.am
@@ -1,5 +1,5 @@
-noinst_LTLIBRARIES = libcommon.la
+noinst_LTLIBRARIES = libcommon4.la # libcommon.la
libcommon_la_SOURCES = \
alloc.h alloc.c \
@@ -51,6 +51,13 @@ libcommon_la_CFLAGS += $(LIBCURL_CFLAGS)
endif
+
+libcommon4_la_SOURCES = \
+ extstr.h extstr.c
+
+libcommon4_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS)
+
+
devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)
dev_HEADERS = $(libcommon_la_SOURCES:%c=)