summaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2024-05-14 20:00:12 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2024-05-14 20:00:12 (GMT)
commited57185faa4d7a53d953cf74a6f8626f44ce9b75 (patch)
treef34cb583e8c0d054676adb9f1da826aa92479d11 /src/core/Makefile.am
parente9f10d8fe1c5e9f8a70801c1cd4d3d342e290f15 (diff)
Restore some logging facilities with automatic switch to the GUI.
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
index ac1ae14..f329a09 100644
--- a/src/core/Makefile.am
+++ b/src/core/Makefile.am
@@ -1,5 +1,5 @@
-noinst_LTLIBRARIES = libcore.la
+noinst_LTLIBRARIES = libcore4.la # libcore.la
libcore_la_SOURCES = \
collections.h collections.c \
@@ -17,6 +17,12 @@ libcore_la_SOURCES = \
libcore_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS)
+libcore4_la_SOURCES = \
+ logs.h logs.c
+
+libcore4_la_CFLAGS = $(TOOLKIT_CFLAGS)
+
+
devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)
dev_HEADERS = $(libcore_la_SOURCES:%c=)