summaryrefslogtreecommitdiff
path: root/src/debug/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2010-12-31 11:49:34 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2010-12-31 11:49:34 (GMT)
commit651c94450df8619c26e26a133289dbaa197616f4 (patch)
tree1a81a2625687116d205cb5c6583497cb657f8460 /src/debug/Makefile.am
parentdbec8e8af5f296f0b95cd9c07e7d96b1a4277137 (diff)
Supported a first basic packet of the Java Debug Wire Protocol.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@204 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/debug/Makefile.am')
-rwxr-xr-xsrc/debug/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/debug/Makefile.am b/src/debug/Makefile.am
index 4369a69..e2e87b8 100755
--- a/src/debug/Makefile.am
+++ b/src/debug/Makefile.am
@@ -3,7 +3,14 @@ noinst_LTLIBRARIES = libdebug.la
libdebug_la_SOURCES = \
break.h break.c \
- debugger.h debugger.c
+ debugger.h debugger.c \
+ packet-int.h \
+ packet.h packet.c \
+ stream-int.h \
+ stream.h stream.c
+
+libdebug_la_LIBADD = \
+ jdwp/libdebugjdwp.la
libdebug_la_CFLAGS = $(AM_CFLAGS)
@@ -14,4 +21,4 @@ AM_CPPFLAGS =
AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-SUBDIRS = remgdb
+SUBDIRS = jdwp remgdb