summaryrefslogtreecommitdiff
path: root/src/debug/jdwp/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2010-12-31 11:49:34 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2010-12-31 11:49:34 (GMT)
commit651c94450df8619c26e26a133289dbaa197616f4 (patch)
tree1a81a2625687116d205cb5c6583497cb657f8460 /src/debug/jdwp/Makefile.am
parentdbec8e8af5f296f0b95cd9c07e7d96b1a4277137 (diff)
Supported a first basic packet of the Java Debug Wire Protocol.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@204 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/debug/jdwp/Makefile.am')
-rw-r--r--src/debug/jdwp/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/debug/jdwp/Makefile.am b/src/debug/jdwp/Makefile.am
new file mode 100644
index 0000000..a9b9c81
--- /dev/null
+++ b/src/debug/jdwp/Makefile.am
@@ -0,0 +1,23 @@
+
+noinst_LTLIBRARIES = libdebugjdwp.la
+
+libdebugjdwp_la_SOURCES = \
+ debugger.h debugger.c \
+ jdwp_def.h \
+ packet.h packet.c \
+ tcp.h tcp.c
+
+libdebugjdwp_la_LIBADD = \
+ misc/libdebugjdwpmisc.la \
+ sets/libdebugjdwpsets.la
+
+libdebugjdwp_la_LDFLAGS =
+
+
+INCLUDES = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS)
+
+AM_CPPFLAGS =
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
+
+SUBDIRS = misc sets