summaryrefslogtreecommitdiff
path: root/src/decomp/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2010-11-11 01:22:43 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2010-11-11 01:22:43 (GMT)
commitb33a52031c0d44a79604bc8d9036c30bffd020cb (patch)
treec825e3330684ca57f7c423328cd116b2d6ec0f6a /src/decomp/Makefile.am
parent828124e38d266e382bb1477ef51c9fac8e81c591 (diff)
Built some expressions for the decompilation tree.
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@190 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/decomp/Makefile.am')
-rwxr-xr-xsrc/decomp/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/decomp/Makefile.am b/src/decomp/Makefile.am
index d77ad29..20694d0 100755
--- a/src/decomp/Makefile.am
+++ b/src/decomp/Makefile.am
@@ -2,10 +2,16 @@
noinst_LTLIBRARIES = libdecomp.la
libdecomp_la_SOURCES = \
+ context.h context.c \
+ expression-int.h \
+ expression.h expression.c \
+ instruction-int.h \
+ instruction.h instruction.c \
output-int.h \
output.h output.c
libdecomp_la_LIBADD = \
+ expr/libdecompexpr.la \
lang/libdecomplang.la
libdecomp_la_LDFLAGS =
@@ -17,4 +23,4 @@ AM_CPPFLAGS =
AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
-SUBDIRS = lang
+SUBDIRS = expr lang