summaryrefslogtreecommitdiff
path: root/src/glibext/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2024-11-15 16:56:56 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2024-11-16 12:33:21 (GMT)
commit80d779749adf228078b61f268bf952ba91a277f0 (patch)
tree34561a4e68296e2ade6da299bafececabfd8abb7 /src/glibext/Makefile.am
parent062861c7cf91b23a59a80172d15e9c084d695265 (diff)
Rename files relative to binary portions.
Diffstat (limited to 'src/glibext/Makefile.am')
-rw-r--r--src/glibext/Makefile.am74
1 files changed, 37 insertions, 37 deletions
diff --git a/src/glibext/Makefile.am b/src/glibext/Makefile.am
index 3649d50..2d4abb8 100644
--- a/src/glibext/Makefile.am
+++ b/src/glibext/Makefile.am
@@ -1,46 +1,46 @@
BUILT_SOURCES = chrysamarshal.h chrysamarshal.c resources.h resources.c
-noinst_LTLIBRARIES = libglibext4.la libglibextui.la # libglibext.la
-
-libglibext_la_SOURCES = \
- comparison-int.h \
- comparison.h comparison.c \
- configuration-int.h \
- configuration.h configuration.c \
- gbinarycursor.h gbinarycursor.c \
- gbinportion-int.h \
- gbinportion.h gbinportion.c \
- glinecursor-int.h \
- glinecursor.h glinecursor.c \
- gnhash.h gnhash.c \
- notifier.h \
- objhole.h \
- proto.h \
- seq.h seq.c \
- _signal.h signal.c \
- singleton.h singleton.c \
- linetoken.h linetoken.c \
- umemslice-int.h \
- umemslice.h umemslice.c
-
-if BUILD_GTK_SUPPORT
-
-libglibext_la_SOURCES += \
- gloadedpanel-int.h \
- gloadedpanel.h gloadedpanel.c \
- named-int.h \
- named.h named.c
-
-endif
-
-libglibext_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS)
+noinst_LTLIBRARIES = libglibext.la libglibextui.la
+
+# libglibext_la_SOURCES = \
+# comparison-int.h \
+# comparison.h comparison.c \
+# configuration-int.h \
+# configuration.h configuration.c \
+# gbinarycursor.h gbinarycursor.c \
+# gbinportion-int.h \
+# gbinportion.h gbinportion.c \
+# glinecursor-int.h \
+# glinecursor.h glinecursor.c \
+# gnhash.h gnhash.c \
+# notifier.h \
+# objhole.h \
+# proto.h \
+# seq.h seq.c \
+# _signal.h signal.c \
+# singleton.h singleton.c \
+# linetoken.h linetoken.c \
+# umemslice-int.h \
+# umemslice.h umemslice.c
+
+# if BUILD_GTK_SUPPORT
+
+# libglibext_la_SOURCES += \
+# gloadedpanel-int.h \
+# gloadedpanel.h gloadedpanel.c \
+# named-int.h \
+# named.h named.c
+
+# endif
+
+# libglibext_la_CFLAGS = $(TOOLKIT_CFLAGS) $(LIBXML_CFLAGS)
#libglibext_la_LIBADD = \
# generators/libglibextgenerators.la
-libglibext4_la_SOURCES = \
+libglibext_la_SOURCES = \
chrysamarshal.h chrysamarshal.c \
helpers.h \
work-int.h \
@@ -50,7 +50,7 @@ libglibext4_la_SOURCES = \
workqueue-int.h \
workqueue.h workqueue.c
-libglibext4_la_CFLAGS = $(TOOLKIT_CFLAGS)
+libglibext_la_CFLAGS = $(TOOLKIT_CFLAGS)
RES_FILES = \
@@ -84,7 +84,7 @@ libglibextui_la_LIBADD = \
devdir = $(includedir)/chrysalide/$(subdir:src/%=core/%)
-dev_HEADERS = $(libglibext_la_SOURCES:%c=)
+dev_HEADERS = $(libglibext_la_SOURCES:%c=) $(libglibextui_la_SOURCES:%c=)
SUBDIRS = generators options