summaryrefslogtreecommitdiff
path: root/src/graph/Makefile.am
diff options
context:
space:
mode:
authorCyrille Bagard <nocbos@gmail.com>2009-06-25 00:34:22 (GMT)
committerCyrille Bagard <nocbos@gmail.com>2009-06-25 00:34:22 (GMT)
commitf2696c85e502e36a529a1d8ee3d209498ac2c0e9 (patch)
tree3d8ffe28a730d32c98e8d048b99f67b7856acec9 /src/graph/Makefile.am
parent23c7cd436e2ec980a68e6d12a6d8a750e357763c (diff)
Used Graphviz library for building graphs (first attempt).
git-svn-id: svn://svn.gna.org/svn/chrysalide/trunk@80 abbe820e-26c8-41b2-8c08-b7b2b41f8b0a
Diffstat (limited to 'src/graph/Makefile.am')
-rwxr-xr-xsrc/graph/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/graph/Makefile.am b/src/graph/Makefile.am
new file mode 100755
index 0000000..e374709
--- /dev/null
+++ b/src/graph/Makefile.am
@@ -0,0 +1,18 @@
+
+noinst_LTLIBRARIES = libgraph.la
+
+libgraph_la_SOURCES = \
+ dot.h dot.c \
+ layout.h layout.c \
+ node.h node.c
+
+libgraph_la_LDFLAGS =
+
+
+INCLUDES = $(LIBGTK_CFLAGS) $(LIBXML_CFLAGS) $(LIBGRAPH_CFLAGS)
+
+AM_CPPFLAGS =
+
+AM_CFLAGS = $(DEBUG_CFLAGS) $(WARNING_FLAGS) $(COMPLIANCE_FLAGS)
+
+SUBDIRS =